summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorMichiel Leenaars <ml.software@leenaa.rs>2016-07-20 18:09:44 +0200
committerMichiel Leenaars <ml.software@leenaa.rs>2016-08-01 09:51:33 +0200
commit55904aa5c402bc5bdc9d34d22a51e7ef0af8a601 (patch)
treed2f8f5a56352dd3addd596b6797bca9e624a1452 /pkgs/tools
parent5bc522913b588a749a2273ce038c31433ffa2a15 (diff)
downloadnixlib-55904aa5c402bc5bdc9d34d22a51e7ef0af8a601.tar
nixlib-55904aa5c402bc5bdc9d34d22a51e7ef0af8a601.tar.gz
nixlib-55904aa5c402bc5bdc9d34d22a51e7ef0af8a601.tar.bz2
nixlib-55904aa5c402bc5bdc9d34d22a51e7ef0af8a601.tar.lz
nixlib-55904aa5c402bc5bdc9d34d22a51e7ef0af8a601.tar.xz
nixlib-55904aa5c402bc5bdc9d34d22a51e7ef0af8a601.tar.zst
nixlib-55904aa5c402bc5bdc9d34d22a51e7ef0af8a601.zip
hash-slinger: init at 2.7.0
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/security/hash-slinger/default.nix44
1 files changed, 44 insertions, 0 deletions
diff --git a/pkgs/tools/security/hash-slinger/default.nix b/pkgs/tools/security/hash-slinger/default.nix
new file mode 100644
index 000000000000..9551c8e36db7
--- /dev/null
+++ b/pkgs/tools/security/hash-slinger/default.nix
@@ -0,0 +1,44 @@
+{ stdenv, fetchFromGitHub, pythonPackages, openssh, gnupg, unbound, libreswan }:
+
+stdenv.mkDerivation rec {
+  pname    = "hash-slinger";
+  name    = "${pname}-${version}";
+  version = "2.7";
+
+  src = fetchFromGitHub {
+    owner = "letoams";
+    repo = "${pname}";
+    rev = "${version}";
+    sha256 = "05wn744ydclpnpyah6yfjqlfjlasrrhzj48lqmm5a91nyps5yqyn";
+  };
+
+  pythonPath = with pythonPackages; [ dns m2crypto ipaddr python-gnupg
+                                      pyunbound ];
+
+  buildInputs = [ pythonPackages.wrapPython ];
+  propagatedBuildInputs = [ unbound libreswan ] ++ pythonPath;
+  propagatedUserEnvPkgs = [ unbound libreswan ];
+
+  patchPhase = ''
+    substituteInPlace Makefile \
+      --replace "$(DESTDIR)/usr" "$out"
+    substituteInPlace ipseckey \
+      --replace "/usr/sbin/ipsec" "${libreswan}/sbin/ipsec"
+    substituteInPlace tlsa \
+      --replace "/var/lib/unbound/root" "${pythonPackages.pyunbound}/etc/pyunbound/root"
+    patchShebangs *
+    '';
+
+  installPhase = ''
+    mkdir -p $out/bin $out/man $out/${python.sitePackages}/
+    make install
+    wrapPythonPrograms
+   '';
+
+   meta = {
+    description = "Various tools to generate special DNS records";
+    homepage    = "https://github.com/letoams/hash-slinger";
+    license     = stdenv.lib.licenses.gpl2Plus;
+    maintainers = [ stdenv.lib.maintainers.leenaars ];
+  };
+}