summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorxeji <36407913+xeji@users.noreply.github.com>2018-08-16 12:34:56 +0200
committerGitHub <noreply@github.com>2018-08-16 12:34:56 +0200
commit4f9c7ea1dfb81630e3ff71bea15b37b7c4164046 (patch)
treea2bb5cafa2ab54829e4b1eac3ce430fbb2e7b7bc /pkgs/tools
parentf207998d792523ef969fc4be0e5419accc313277 (diff)
parent5c395d5095ed9f04fffdbda5da74c5867350e540 (diff)
downloadnixlib-4f9c7ea1dfb81630e3ff71bea15b37b7c4164046.tar
nixlib-4f9c7ea1dfb81630e3ff71bea15b37b7c4164046.tar.gz
nixlib-4f9c7ea1dfb81630e3ff71bea15b37b7c4164046.tar.bz2
nixlib-4f9c7ea1dfb81630e3ff71bea15b37b7c4164046.tar.lz
nixlib-4f9c7ea1dfb81630e3ff71bea15b37b7c4164046.tar.xz
nixlib-4f9c7ea1dfb81630e3ff71bea15b37b7c4164046.tar.zst
nixlib-4f9c7ea1dfb81630e3ff71bea15b37b7c4164046.zip
Merge pull request #45077 from markuskowa/licenses-c
Add license meta tags
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/archivers/cpio/default.nix5
-rw-r--r--pkgs/tools/archivers/cromfs/default.nix7
-rw-r--r--pkgs/tools/misc/cowsay/default.nix9
-rw-r--r--pkgs/tools/system/cron/default.nix7
-rw-r--r--pkgs/tools/virtualization/cri-tools/default.nix6
5 files changed, 21 insertions, 13 deletions
diff --git a/pkgs/tools/archivers/cpio/default.nix b/pkgs/tools/archivers/cpio/default.nix
index 2313f27f2e54..c38dc7bbfbe7 100644
--- a/pkgs/tools/archivers/cpio/default.nix
+++ b/pkgs/tools/archivers/cpio/default.nix
@@ -31,10 +31,11 @@ in stdenv.mkDerivation {
 
   enableParallelBuilding = true;
 
-  meta = {
+  meta = with stdenv.lib; {
     homepage = http://www.gnu.org/software/cpio/;
     description = "A program to create or extract from cpio archives";
-    platforms = stdenv.lib.platforms.all;
+    license = licenses.gpl3;
+    platforms = platforms.all;
     priority = 6; # resolves collision with gnutar's "libexec/rmt"
   };
 }
diff --git a/pkgs/tools/archivers/cromfs/default.nix b/pkgs/tools/archivers/cromfs/default.nix
index 68f7f02e7413..57a8a8e97380 100644
--- a/pkgs/tools/archivers/cromfs/default.nix
+++ b/pkgs/tools/archivers/cromfs/default.nix
@@ -21,10 +21,11 @@ stdenv.mkDerivation rec {
   nativeBuildInputs = [ pkgconfig ];
   buildInputs = [ fuse perl ];
 
-  meta = {
+  meta = with stdenv.lib; {
     description = "FUSE Compressed ROM filesystem with lzma";
     homepage = https://bisqwit.iki.fi/source/cromfs.html;
-    maintainers = [ stdenv.lib.maintainers.viric ];
-    platforms = stdenv.lib.platforms.linux;
+    license = licenses.gpl3;
+    maintainers = [ maintainers.viric ];
+    platforms = platforms.linux;
   };
 }
diff --git a/pkgs/tools/misc/cowsay/default.nix b/pkgs/tools/misc/cowsay/default.nix
index 0a7b079445d5..bb874dd002a7 100644
--- a/pkgs/tools/misc/cowsay/default.nix
+++ b/pkgs/tools/misc/cowsay/default.nix
@@ -15,10 +15,11 @@ stdenv.mkDerivation {
     bash ./install.sh $out
   '';
 
-  meta = {
+  meta = with stdenv.lib; {
     description = "A program which generates ASCII pictures of a cow with a message";
-    homepage = http://www.nog.net/~tony/warez/cowsay.shtml;
-    platforms = stdenv.lib.platforms.all;
-    maintainers = [ stdenv.lib.maintainers.rob ];
+    homepage = https://en.wikipedia.org/wiki/Cowsay;
+    license = licenses.gpl1;
+    platforms = platforms.all;
+    maintainers = [ maintainers.rob ];
   };
 }
diff --git a/pkgs/tools/system/cron/default.nix b/pkgs/tools/system/cron/default.nix
index d6347798053b..374f0ac19d89 100644
--- a/pkgs/tools/system/cron/default.nix
+++ b/pkgs/tools/system/cron/default.nix
@@ -12,7 +12,7 @@ stdenv.mkDerivation {
   hardeningEnable = [ "pie" ];
 
   preBuild = ''
-    # do not set sticky bit in /nix/store 
+    # do not set sticky bit in /nix/store
     substituteInPlace Makefile --replace ' -o root' ' ' --replace 111 755 --replace 4755 0755
     # do not strip during install, broken on cross and we'll do ourselves as needed
     substituteInPlace Makefile --replace ' -s cron' ' cron'
@@ -36,8 +36,9 @@ stdenv.mkDerivation {
 
   preInstall = "mkdir -p $out/bin $out/sbin $out/share/man/man1 $out/share/man/man5 $out/share/man/man8";
 
-  meta = {
+  meta = with stdenv.lib; {
     description = "Daemon for running commands at specific times (Vixie Cron)";
-    platforms = with stdenv.lib.platforms; linux ++ darwin;
+    license = licenses.bsd0;
+    platforms = with platforms; linux ++ darwin;
   };
 }
diff --git a/pkgs/tools/virtualization/cri-tools/default.nix b/pkgs/tools/virtualization/cri-tools/default.nix
index 120727f3873d..f57befce3081 100644
--- a/pkgs/tools/virtualization/cri-tools/default.nix
+++ b/pkgs/tools/virtualization/cri-tools/default.nix
@@ -1,4 +1,4 @@
-{ buildGoPackage, fetchurl }:
+{ buildGoPackage, fetchurl, lib }:
 
 buildGoPackage
   { name = "cri-tools-1.0.0-alpha.0";
@@ -10,6 +10,10 @@ buildGoPackage
     goPackagePath = "github.com/kubernetes-incubator/cri-tools";
     subPackages = [ "cmd/crictl" "cmd/critest" ];
 
+    meta = {
+      license = lib.licenses.asl20;
+    };
+
     goDeps = ./deps.nix;
   }