summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorjoachifm <joachifm@users.noreply.github.com>2016-03-22 00:44:49 +0000
committerjoachifm <joachifm@users.noreply.github.com>2016-03-22 00:44:49 +0000
commit4f29a8c03e57e4fb3316e1e55573b1b02cd644da (patch)
tree18ac84279daabaaa2535c022abc72273542872c4 /pkgs/tools
parent29275f9740283a7feee649ba29ef55ef88d2da93 (diff)
parent5c740539a889298ff285afc86584231d608e2893 (diff)
downloadnixlib-4f29a8c03e57e4fb3316e1e55573b1b02cd644da.tar
nixlib-4f29a8c03e57e4fb3316e1e55573b1b02cd644da.tar.gz
nixlib-4f29a8c03e57e4fb3316e1e55573b1b02cd644da.tar.bz2
nixlib-4f29a8c03e57e4fb3316e1e55573b1b02cd644da.tar.lz
nixlib-4f29a8c03e57e4fb3316e1e55573b1b02cd644da.tar.xz
nixlib-4f29a8c03e57e4fb3316e1e55573b1b02cd644da.tar.zst
nixlib-4f29a8c03e57e4fb3316e1e55573b1b02cd644da.zip
Merge pull request #14023 from Adjective-Object/add/ansifilter
ansifilter: add @ 1.15
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/text/ansifilter/default.nix27
1 files changed, 27 insertions, 0 deletions
diff --git a/pkgs/tools/text/ansifilter/default.nix b/pkgs/tools/text/ansifilter/default.nix
new file mode 100644
index 000000000000..e47369f47559
--- /dev/null
+++ b/pkgs/tools/text/ansifilter/default.nix
@@ -0,0 +1,27 @@
+{ fetchurl, stdenv, pkgconfig, boost, lua }:
+let version = "1.15";
+    pkgsha = "65dc20cc1a03d4feba990f830186404c90462d599e5f4b37610d4d822d67aec4";
+in stdenv.mkDerivation {
+  name = "ansifilter-${version}";
+  buildInputs = [
+    pkgconfig boost lua
+  ];
+  src = fetchurl {
+    url = "http://www.andre-simon.de/zip/ansifilter-${version}.tar.bz2";
+    sha256 = pkgsha;
+  };
+  meta = {
+    description = "Tool to convert ANSI to other formats";
+    longDescription = ''
+    Tool to remove ANSI or convert them to another format 
+    (HTML, TeX, LaTeX, RTF, Pango or BBCode)
+    '';
+
+    license = stdenv.lib.licenses.gpl1;
+    maintainers = [ stdenv.lib.maintainers.Adjective-Object ];
+  };
+
+  makeFlags="PREFIX=$(out) conf_dir=$(out)/etc/ansifilter/";
+
+}
+