summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2005-04-22 18:26:04 +0000
committerEelco Dolstra <eelco.dolstra@logicblox.com>2005-04-22 18:26:04 +0000
commit4e4ad61aeee8d4fa44525bd0ffac085663ab3552 (patch)
tree571b1d20997146cf50c90d63173177cff05d92fc /pkgs/tools
parent2ed47f7522c4bcdade3ac803b7e93218e7225ac4 (diff)
downloadnixlib-4e4ad61aeee8d4fa44525bd0ffac085663ab3552.tar
nixlib-4e4ad61aeee8d4fa44525bd0ffac085663ab3552.tar.gz
nixlib-4e4ad61aeee8d4fa44525bd0ffac085663ab3552.tar.bz2
nixlib-4e4ad61aeee8d4fa44525bd0ffac085663ab3552.tar.lz
nixlib-4e4ad61aeee8d4fa44525bd0ffac085663ab3552.tar.xz
nixlib-4e4ad61aeee8d4fa44525bd0ffac085663ab3552.tar.zst
nixlib-4e4ad61aeee8d4fa44525bd0ffac085663ab3552.zip
* Added pygtk.
* Updated bittorrent to 4.0.1.

svn path=/nixpkgs/trunk/; revision=2879
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/networking/bittorrent/builder.sh16
-rw-r--r--pkgs/tools/networking/bittorrent/default.nix14
2 files changed, 13 insertions, 17 deletions
diff --git a/pkgs/tools/networking/bittorrent/builder.sh b/pkgs/tools/networking/bittorrent/builder.sh
index c9114a785007..ba195a02e159 100644
--- a/pkgs/tools/networking/bittorrent/builder.sh
+++ b/pkgs/tools/networking/bittorrent/builder.sh
@@ -1,5 +1,5 @@
-buildInputs="$python $wxPython"
 . $stdenv/setup
+. $makeWrapper
 
 buildPhase=buildPhase
 buildPhase() {
@@ -11,14 +11,12 @@ installPhase() {
     python setup.py install --prefix=$out
 
     # Create wrappers that set the environment correctly.
-    mv $out/bin $out/bin-orig
-    mkdir $out/bin
-    for i in $(cd $out/bin-orig && ls); do
-        cat > $out/bin/$i <<EOF
-#! /bin/sh
-PYTHONPATH=$out/lib/python2.3/site-packages:$wxPython/lib/python2.3/site-packages exec $out/bin-orig/$i "\$@"
-EOF
-        chmod +x $out/bin/$i
+    for i in $(cd $out/bin && ls); do
+        # Note: the GUI apps except to be in a directory called `bin',
+        # so don't move them. 
+        mv $out/bin/$i $out/bin/.orig-$i
+        makeWrapper $out/bin/.orig-$i $out/bin/$i \
+            --set PYTHONPATH "$out/lib/python2.3/site-packages:$pygtk/lib/python2.3/site-packages/gtk-2.0"
     done
 }
 
diff --git a/pkgs/tools/networking/bittorrent/default.nix b/pkgs/tools/networking/bittorrent/default.nix
index f516ea4225aa..e9d73d16073a 100644
--- a/pkgs/tools/networking/bittorrent/default.nix
+++ b/pkgs/tools/networking/bittorrent/default.nix
@@ -1,14 +1,12 @@
-{stdenv, fetchurl, wxPython}:
-
-assert wxPython.python.zlibSupport;
+{stdenv, fetchurl, python, pygtk, makeWrapper}:
 
 stdenv.mkDerivation {
-  name = "bittorrent-3.4.2";
+  name = "bittorrent-4.0.1";
   builder = ./builder.sh;
   src = fetchurl {
-    url = http://catamaran.labs.cs.uu.nl/dist/tarballs/BitTorrent-3.4.2.tar.gz;
-    md5 = "b854f25a33289565bcaeaded04955c1a";
+    url = http://www.bittorrent.com/dl/BitTorrent-4.0.1.tar.gz;
+    md5 = "e890d856d43b3d0af14b28714bc5801a";
   };
-  inherit wxPython;
-  inherit (wxPython) python;
+  buildInputs = [python pygtk];
+  inherit python pygtk makeWrapper;
 }