summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorTim Steinbach <NeQuissimus@users.noreply.github.com>2017-07-25 09:17:23 -0400
committerGitHub <noreply@github.com>2017-07-25 09:17:23 -0400
commit4a4a33ff8892293006b407aad836d5a3544e638c (patch)
tree7616ac7cddd642835bc93a9863ac0400f5404f48 /pkgs/tools
parentaba21d99dad5641daf32c8051994cc8afd8ff3c4 (diff)
parent6e00673e7fd1784256b5e72ca54598dd9de46dbf (diff)
downloadnixlib-4a4a33ff8892293006b407aad836d5a3544e638c.tar
nixlib-4a4a33ff8892293006b407aad836d5a3544e638c.tar.gz
nixlib-4a4a33ff8892293006b407aad836d5a3544e638c.tar.bz2
nixlib-4a4a33ff8892293006b407aad836d5a3544e638c.tar.lz
nixlib-4a4a33ff8892293006b407aad836d5a3544e638c.tar.xz
nixlib-4a4a33ff8892293006b407aad836d5a3544e638c.tar.zst
nixlib-4a4a33ff8892293006b407aad836d5a3544e638c.zip
Merge pull request #27582 from NeQuissimus/remove_accelio
accelio: Remove
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/filesystems/ceph/generic.nix10
1 files changed, 1 insertions, 9 deletions
diff --git a/pkgs/tools/filesystems/ceph/generic.nix b/pkgs/tools/filesystems/ceph/generic.nix
index e4c8b0f33bcd..0af97dd3b540 100644
--- a/pkgs/tools/filesystems/ceph/generic.nix
+++ b/pkgs/tools/filesystems/ceph/generic.nix
@@ -4,7 +4,7 @@
 
 # Optional Dependencies
 , snappy ? null, leveldb ? null, yasm ? null, fcgi ? null, expat ? null
-, curl ? null, fuse ? null, accelio ? null, libibverbs ? null, librdmacm ? null
+, curl ? null, fuse ? null, libibverbs ? null, librdmacm ? null
 , libedit ? null, libatomic_ops ? null, kinetic-cpp-client ? null
 , rocksdb ? null, libs3 ? null
 
@@ -50,7 +50,6 @@ let
   optExpat = shouldUsePkg expat;
   optCurl = shouldUsePkg curl;
   optFuse = shouldUsePkg fuse;
-  optAccelio = shouldUsePkg accelio;
   optLibibverbs = shouldUsePkg libibverbs;
   optLibrdmacm = shouldUsePkg librdmacm;
   optLibedit = shouldUsePkg libedit;
@@ -76,10 +75,6 @@ let
   hasOsd = hasServer;
   hasRadosgw = optFcgi != null && optExpat != null && optCurl != null && optLibedit != null;
 
-  hasXio = (stdenv.isLinux || stdenv.isFreeBSD) &&
-    versionAtLeast version "9.0.3" &&
-    optAccelio != null && optLibibverbs != null && optLibrdmacm != null;
-
   hasRocksdb = versionAtLeast version "9.0.0" && optRocksdb != null;
 
   # TODO: Reenable when kinetic support is fixed
@@ -128,8 +123,6 @@ stdenv.mkDerivation {
     optSnappy optLeveldb
   ] ++ optionals hasRadosgw [
     optFcgi optExpat optCurl optFuse optLibedit
-  ] ++ optionals hasXio [
-    optAccelio optLibibverbs optLibrdmacm
   ] ++ optionals hasRocksdb [
     optRocksdb
   ] ++ optionals hasKinetic [
@@ -192,7 +185,6 @@ stdenv.mkDerivation {
     (mkWith   (malloc == optGperftools)    "tcmalloc"             null)
     (mkEnable false                        "pgrefdebugging"       null)
     (mkEnable false                        "cephfs-java"          null)
-    (mkEnable hasXio                       "xio"                  null)
     (mkWith   (optLibatomic_ops != null)   "libatomic-ops"        null)
     (mkWith   true                         "ocf"                  null)
     (mkWith   hasKinetic                   "kinetic"              null)