summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2009-10-13 21:34:54 +0000
committerLudovic Courtès <ludo@gnu.org>2009-10-13 21:34:54 +0000
commit40495327c5e268ea1c447766ce60ca1e62d5a4a5 (patch)
tree24bd1723257e6b3393db773c1bcca94e5982f5f0 /pkgs/tools
parent131c5f7e339ac7e14729523567b39a4f6454950f (diff)
downloadnixlib-40495327c5e268ea1c447766ce60ca1e62d5a4a5.tar
nixlib-40495327c5e268ea1c447766ce60ca1e62d5a4a5.tar.gz
nixlib-40495327c5e268ea1c447766ce60ca1e62d5a4a5.tar.bz2
nixlib-40495327c5e268ea1c447766ce60ca1e62d5a4a5.tar.lz
nixlib-40495327c5e268ea1c447766ce60ca1e62d5a4a5.tar.xz
nixlib-40495327c5e268ea1c447766ce60ca1e62d5a4a5.tar.zst
nixlib-40495327c5e268ea1c447766ce60ca1e62d5a4a5.zip
GRUB 2: Add GNU Unifont BDF font.
svn path=/nixpkgs/trunk/; revision=17791
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/misc/grub/1.9x.nix12
1 files changed, 12 insertions, 0 deletions
diff --git a/pkgs/tools/misc/grub/1.9x.nix b/pkgs/tools/misc/grub/1.9x.nix
index cd701ce66c93..26498758fb0b 100644
--- a/pkgs/tools/misc/grub/1.9x.nix
+++ b/pkgs/tools/misc/grub/1.9x.nix
@@ -1,5 +1,11 @@
 { fetchurl, stdenv, bison, ncurses, libusb, freetype }:
 
+let unifont_bdf = fetchurl {
+      url = "http://unifoundry.com/unifont-5.1.20080820.bdf.gz";
+      sha256 = "0s0qfff6n6282q28nwwblp5x295zd6n71kl43xj40vgvdqxv0fxx";
+    };
+in
+
 stdenv.mkDerivation rec {
   name = "grub-1.97beta3";
 
@@ -11,6 +17,12 @@ stdenv.mkDerivation rec {
 
   buildInputs = [ bison ncurses libusb freetype ];
 
+  patchPhase =
+    '' gunzip < "${unifont_bdf}" > "unifont.bdf"
+       sed -i "configure" \
+           -e "s|/usr/src/unifont.bdf|$PWD/unifont.bdf|g"
+    '';
+
   doCheck = true;
 
   meta = {