summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorFrederik Rietdijk <fridh@fridh.nl>2016-08-30 12:20:25 +0200
committerFrederik Rietdijk <fridh@fridh.nl>2016-08-30 12:20:25 +0200
commit400d1d5c89741c2d6e94aa5c60b13f03fdc53e1c (patch)
tree151483cf60680c6a30f98764b6f1a3b30a2315fd /pkgs/tools
parent6f1d7d67c0227d7880532aa9016bbefec2b42bd2 (diff)
downloadnixlib-400d1d5c89741c2d6e94aa5c60b13f03fdc53e1c.tar
nixlib-400d1d5c89741c2d6e94aa5c60b13f03fdc53e1c.tar.gz
nixlib-400d1d5c89741c2d6e94aa5c60b13f03fdc53e1c.tar.bz2
nixlib-400d1d5c89741c2d6e94aa5c60b13f03fdc53e1c.tar.lz
nixlib-400d1d5c89741c2d6e94aa5c60b13f03fdc53e1c.tar.xz
nixlib-400d1d5c89741c2d6e94aa5c60b13f03fdc53e1c.tar.zst
nixlib-400d1d5c89741c2d6e94aa5c60b13f03fdc53e1c.zip
duply: add pythonPackages.cryptography
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/backup/duply/default.nix8
1 files changed, 5 insertions, 3 deletions
diff --git a/pkgs/tools/backup/duply/default.nix b/pkgs/tools/backup/duply/default.nix
index a055b87c2631..5bde5e78afad 100644
--- a/pkgs/tools/backup/duply/default.nix
+++ b/pkgs/tools/backup/duply/default.nix
@@ -2,7 +2,9 @@
 , gnugrep, txt2man, makeWrapper, which
 }:
 
-stdenv.mkDerivation {
+let
+  pythonEnv = python.withPackages (ps: [ps.cryptography] );
+in stdenv.mkDerivation {
   name = "duply-1.9.2";
 
   src = fetchurl {
@@ -11,7 +13,7 @@ stdenv.mkDerivation {
   };
 
   buildInputs = [ txt2man makeWrapper ];
-
+  propagatedBuildInputs = [ pythonEnv ];
   phases = [ "unpackPhase" "installPhase" ];
 
   installPhase = ''
@@ -20,7 +22,7 @@ stdenv.mkDerivation {
     sed -i 's|/usr/bin/env bash|${bash}/bin/bash|' duply
     mv duply "$out/bin"
     wrapProgram "$out/bin/duply" --set PATH \
-        "${coreutils}/bin:${python}/bin:${duplicity}/bin:${gawk}/bin:${gnupg1}/bin:${bash}/bin:${gnugrep}/bin:${txt2man}/bin:${which}/bin"
+        "${coreutils}/bin:${pythonEnv}/bin:${duplicity}/bin:${gawk}/bin:${gnupg1}/bin:${bash}/bin:${gnugrep}/bin:${txt2man}/bin:${which}/bin"
     "$out/bin/duply" txt2man | gzip -c > "$out/share/man/man1/duply.1.gz"
   '';