summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorDomen Kožar <domen@dev.si>2013-08-07 05:11:51 -0700
committerDomen Kožar <domen@dev.si>2013-08-07 05:11:51 -0700
commit3cf22b53070cb9338405f223e55c6e9bcc77ea09 (patch)
treebf9df68670be12cc25965c537e77ec00bda40b6c /pkgs/tools
parent12cc79f8449f52eacc7f9be2e3ca41dc9ea3ef03 (diff)
parentd4ba4769b6f6db42c01c5eb31b0f6ab27d13648e (diff)
downloadnixlib-3cf22b53070cb9338405f223e55c6e9bcc77ea09.tar
nixlib-3cf22b53070cb9338405f223e55c6e9bcc77ea09.tar.gz
nixlib-3cf22b53070cb9338405f223e55c6e9bcc77ea09.tar.bz2
nixlib-3cf22b53070cb9338405f223e55c6e9bcc77ea09.tar.lz
nixlib-3cf22b53070cb9338405f223e55c6e9bcc77ea09.tar.xz
nixlib-3cf22b53070cb9338405f223e55c6e9bcc77ea09.tar.zst
nixlib-3cf22b53070cb9338405f223e55c6e9bcc77ea09.zip
Merge pull request #805 from lovek323/pass
password-store: add expression
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/security/pass/default.nix48
1 files changed, 48 insertions, 0 deletions
diff --git a/pkgs/tools/security/pass/default.nix b/pkgs/tools/security/pass/default.nix
new file mode 100644
index 000000000000..ba86b0b1d9ce
--- /dev/null
+++ b/pkgs/tools/security/pass/default.nix
@@ -0,0 +1,48 @@
+{ stdenv, fetchurl, getopt }:
+
+stdenv.mkDerivation rec {
+  version = "1.4.2";
+  name    = "password-store-${version}";
+
+  src = fetchurl {
+    url    = "http://git.zx2c4.com/password-store/snapshot/${name}.tar.xz";
+    sha256 = "00m3q6dihrhw8cxsrham3bdqg5841an8ch4s3a4k5fynlcb802m1";
+  };
+
+  meta = with stdenv.lib; {
+    description = "Stores, retrieves, generates, and synchronizes passwords securely.";
+    homepage    = http://zx2c4.com/projects/password-store/;
+    license     = licenses.gpl2Plus;
+    maintainers = with maintainers; [ lovek323 ];
+    platforms   = platforms.unix;
+
+    longDescription = ''
+      pass is a very simple password store that keeps passwords inside gpg2
+      encrypted files inside a simple directory tree residing at
+      ~/.password-store. The pass utility provides a series of commands for
+      manipulating the password store, allowing the user to add, remove, edit,
+      synchronize, generate, and manipulate passwords.
+    '';
+  };
+
+  propagatedBuildInputs = [ getopt ];
+
+  installPhase = ''
+    # link zsh and fish completions
+    sed -ie '22s/^#//' Makefile
+    sed -ie '25s/^#//' Makefile
+    sed -i 's/find /find -L /' contrib/pass.zsh-completion
+    mkdir -p "$out/share/zsh/site-functions"
+    mkdir -p "$out/share/fish/completions"
+
+    # use gnused
+    sed -i 's/sed -i ""/sed -i /' Makefile
+
+    SYSCONFDIR="$out/etc" PREFIX="$out" make install
+  '' + stdenv.lib.optionalString stdenv.isDarwin ''
+    # use nix-supplied getopt
+    sed -ie '34c GETOPT="${getopt}/bin/getopt"' \
+      "$out/lib/password-store.platform.sh"
+  '';
+}
+