summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorTuomas Tynkkynen <tuomas.tynkkynen@iki.fi>2016-09-03 01:27:10 +0300
committerGitHub <noreply@github.com>2016-09-03 01:27:10 +0300
commit3949abee6501f41dda9d057810c458e33f38223b (patch)
tree9c2029342030441484b13931f8b96e41503fae35 /pkgs/tools
parente2c6740c37428f8d8185fcc907e9e619df50be85 (diff)
parent498d803cce9aadca253f8fb8c37604c7f856d6eb (diff)
downloadnixlib-3949abee6501f41dda9d057810c458e33f38223b.tar
nixlib-3949abee6501f41dda9d057810c458e33f38223b.tar.gz
nixlib-3949abee6501f41dda9d057810c458e33f38223b.tar.bz2
nixlib-3949abee6501f41dda9d057810c458e33f38223b.tar.lz
nixlib-3949abee6501f41dda9d057810c458e33f38223b.tar.xz
nixlib-3949abee6501f41dda9d057810c458e33f38223b.tar.zst
nixlib-3949abee6501f41dda9d057810c458e33f38223b.zip
Merge pull request #18230 from eikek/recutils-1.7
recutils: 1.5 -> 1.7
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/misc/recutils/default.nix10
-rw-r--r--pkgs/tools/misc/recutils/glibc.patch29
2 files changed, 6 insertions, 33 deletions
diff --git a/pkgs/tools/misc/recutils/default.nix b/pkgs/tools/misc/recutils/default.nix
index 6dd40e8476f3..f1712a43c3be 100644
--- a/pkgs/tools/misc/recutils/default.nix
+++ b/pkgs/tools/misc/recutils/default.nix
@@ -1,21 +1,23 @@
 { fetchurl, stdenv, gettext, emacs, curl, check, bc }:
 
 stdenv.mkDerivation rec {
-  name = "recutils-1.5";
+  name = "recutils-1.7";
 
   src = fetchurl {
     url = "mirror://gnu/recutils/${name}.tar.gz";
-    sha256 = "1v2xzwwwhc5j5kmvg4sv6baxjpsfqh8ln7ilv4mgb1408rs7xmky";
+    sha256 = "0cdwa4094x3yx7vn98xykvnlp9rngvd58d19vs3vh5hrvggccg93";
   };
 
-  patches = [ ./glibc.patch ];
-
   doCheck = true;
 
   hardeningDisable = [ "format" ];
 
   buildInputs = [ curl emacs ] ++ (stdenv.lib.optionals doCheck [ check bc ]);
 
+  postInstall = ''
+    ${emacs}/bin/emacs -Q -batch -f batch-byte-compile $out/share/emacs/site-lisp/*.el #*/
+  '';
+
   meta = {
     description = "Tools and libraries to access human-editable, text-based databases";
 
diff --git a/pkgs/tools/misc/recutils/glibc.patch b/pkgs/tools/misc/recutils/glibc.patch
deleted file mode 100644
index 8b4997f099de..000000000000
--- a/pkgs/tools/misc/recutils/glibc.patch
+++ /dev/null
@@ -1,29 +0,0 @@
---- recutils-1.5/lib/stdio.in.h
-+++ recutils-1.5/lib/stdio.in.h
-@@ -699,22 +699,11 @@
- # endif
- #endif
- 
--#if @GNULIB_GETS@
--# if @REPLACE_STDIO_READ_FUNCS@ && @GNULIB_STDIO_H_NONBLOCKING@
--#  if !(defined __cplusplus && defined GNULIB_NAMESPACE)
--#   undef gets
--#   define gets rpl_gets
--#  endif
--_GL_FUNCDECL_RPL (gets, char *, (char *s) _GL_ARG_NONNULL ((1)));
--_GL_CXXALIAS_RPL (gets, char *, (char *s));
--# else
--_GL_CXXALIAS_SYS (gets, char *, (char *s));
--#  undef gets
--# endif
--_GL_CXXALIASWARN (gets);
- /* It is very rare that the developer ever has full control of stdin,
--   so any use of gets warrants an unconditional warning.  Assume it is
--   always declared, since it is required by C89.  */
-+   so any use of gets warrants an unconditional warning; besides, C11
-+   removed it.  */
-+#undef gets
-+#if HAVE_RAW_DECL_GETS
- _GL_WARN_ON_USE (gets, "gets is a security hole - use fgets instead");
- #endif
-