summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorMatthew Justin Bauer <mjbauer95@gmail.com>2018-03-31 19:23:14 -0500
committerGitHub <noreply@github.com>2018-03-31 19:23:14 -0500
commit377f6f39f1d1d18ee80b80e5d17caea1a8e3d09f (patch)
tree829366494d747632c24a52c1da81ca2ea506f894 /pkgs/tools
parentc7adb9ddc8e52bde7daed633e7ef0f5cbf36f4cb (diff)
parentedc878659146d2c71e3e04b41517bd0e319566f7 (diff)
downloadnixlib-377f6f39f1d1d18ee80b80e5d17caea1a8e3d09f.tar
nixlib-377f6f39f1d1d18ee80b80e5d17caea1a8e3d09f.tar.gz
nixlib-377f6f39f1d1d18ee80b80e5d17caea1a8e3d09f.tar.bz2
nixlib-377f6f39f1d1d18ee80b80e5d17caea1a8e3d09f.tar.lz
nixlib-377f6f39f1d1d18ee80b80e5d17caea1a8e3d09f.tar.xz
nixlib-377f6f39f1d1d18ee80b80e5d17caea1a8e3d09f.tar.zst
nixlib-377f6f39f1d1d18ee80b80e5d17caea1a8e3d09f.zip
Merge pull request #37821 from redfish64/master
init cconv at 0.6.3
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/text/cconv/default.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/pkgs/tools/text/cconv/default.nix b/pkgs/tools/text/cconv/default.nix
new file mode 100644
index 000000000000..9f6b7a7f1227
--- /dev/null
+++ b/pkgs/tools/text/cconv/default.nix
@@ -0,0 +1,20 @@
+{ stdenv, fetchurl, autoreconfHook }:
+let version = "0.6.3"; in
+  stdenv.mkDerivation {
+  name = "cconv-${version}";
+  
+  src = fetchurl {
+    url = "https://github.com/xiaoyjy/cconv/archive/v${version}.tar.gz";
+    sha256 = "82f46a94829f5a8157d6f686e302ff5710108931973e133d6e19593061b81d84";
+  };
+
+  nativeBuildInputs = [ autoreconfHook ];
+  
+  meta = with stdenv.lib; {
+    description = "A iconv based simplified-traditional chinese conversion tool";
+    homepage = https://github.com/xiaoyjy/cconv;
+    license = licenses.mit;
+    platforms = platforms.linux;
+    maintainers = [ maintainers.redfish64 ];
+  };
+}