summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorPascal Wittmann <mail@pascal-wittmann.de>2014-09-22 00:05:52 +0200
committerPascal Wittmann <mail@pascal-wittmann.de>2014-09-22 00:06:29 +0200
commit363b6da6a715d8f53a2d7cb5f12e0d018c385330 (patch)
tree1ddb6b2a787a7dad0cfffee2e45a122595a87041 /pkgs/tools
parent837fef324df2020c169a037de3b9f65820975df7 (diff)
downloadnixlib-363b6da6a715d8f53a2d7cb5f12e0d018c385330.tar
nixlib-363b6da6a715d8f53a2d7cb5f12e0d018c385330.tar.gz
nixlib-363b6da6a715d8f53a2d7cb5f12e0d018c385330.tar.bz2
nixlib-363b6da6a715d8f53a2d7cb5f12e0d018c385330.tar.lz
nixlib-363b6da6a715d8f53a2d7cb5f12e0d018c385330.tar.xz
nixlib-363b6da6a715d8f53a2d7cb5f12e0d018c385330.tar.zst
nixlib-363b6da6a715d8f53a2d7cb5f12e0d018c385330.zip
bmon: update from 3.1 to 3.5 and added myself as maintainer
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/misc/bmon/default.nix32
1 files changed, 18 insertions, 14 deletions
diff --git a/pkgs/tools/misc/bmon/default.nix b/pkgs/tools/misc/bmon/default.nix
index 29a6db4e6d27..4a1a272cc0fe 100644
--- a/pkgs/tools/misc/bmon/default.nix
+++ b/pkgs/tools/misc/bmon/default.nix
@@ -1,25 +1,29 @@
-{ stdenv, fetchurl, pkgconfig, ncurses, confuse, libnl }:
+{ stdenv, fetchFromGitHub, autoconf, automake, pkgconfig, ncurses, confuse
+, libnl }:
 
-stdenv.mkDerivation {
-  name = "bmon-3.1";
+stdenv.mkDerivation rec {
+  name = "bmon-${version}";
+  version = "3.5";
 
-  src = fetchurl {
-    url = http://www.carisma.slowglass.com/~tgr/bmon/files/bmon-3.1.tar.gz;
-    sha256 = "005ib7c3g3cva0rdwsgl6hfakxd5yp88sf4bjxb6iarcm3ax18ky";
+  src = fetchFromGitHub {
+    owner = "tgraf";
+    repo = "bmon";
+    rev = "v${version}";
+    sha256 = "0k6cwprwnrnilbs2fgkx7z9mg6rr11wf6djq6pjfc7fjn2fjvybi";
   };
 
-  buildInputs = [ pkgconfig ncurses confuse libnl ];
+  buildInputs = [ autoconf automake pkgconfig ncurses confuse libnl ];
+
+  preConfigure = "sh ./autogen.sh";
 
   meta = with stdenv.lib; {
     description = "Network bandwidth monitor";
-    homepage = http://www.carisma.slowglass.com/~tgr/bmon/;
-    # Neither the homepage nor the source archive has license info, but in the
-    # latest git version there is a LICENSE file that is the 2-clause BSD
-    # license.
-    #  - https://github.com/tgraf/bmon/blob/master/LICENSE
-    #  - http://opensource.org/licenses/BSD-2-Clause
+    homepage = https://github.com/tgraf/bmon;
+    # Licensed unter BSD and MIT
+    #  - https://github.com/tgraf/bmon/blob/master/LICENSE.BSD
+    #  - https://github.com/tgraf/bmon/blob/master/LICENSE.MIT
     license = licenses.bsd2;
     platforms = platforms.linux;
-    maintainers = [ maintainers.bjornfor ];
+    maintainers = with maintainers; [ bjornfor pSub ];
   };
 }