summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorShea Levy <shea@shealevy.com>2014-04-06 10:54:44 -0400
committerShea Levy <shea@shealevy.com>2014-04-06 10:54:44 -0400
commit331d234ef6ecd6f32fb2a589a9a97ebf0bf85a9c (patch)
tree6002cd88db5a7ed836a07bab78f8a1c100935a22 /pkgs/tools
parent29bc5feb1d120f16f348c4af22da58ef67bc6143 (diff)
downloadnixlib-331d234ef6ecd6f32fb2a589a9a97ebf0bf85a9c.tar
nixlib-331d234ef6ecd6f32fb2a589a9a97ebf0bf85a9c.tar.gz
nixlib-331d234ef6ecd6f32fb2a589a9a97ebf0bf85a9c.tar.bz2
nixlib-331d234ef6ecd6f32fb2a589a9a97ebf0bf85a9c.tar.lz
nixlib-331d234ef6ecd6f32fb2a589a9a97ebf0bf85a9c.tar.xz
nixlib-331d234ef6ecd6f32fb2a589a9a97ebf0bf85a9c.tar.zst
nixlib-331d234ef6ecd6f32fb2a589a9a97ebf0bf85a9c.zip
Add sproxy
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/networking/sproxy/default.nix36
1 files changed, 36 insertions, 0 deletions
diff --git a/pkgs/tools/networking/sproxy/default.nix b/pkgs/tools/networking/sproxy/default.nix
new file mode 100644
index 000000000000..342da193ffc7
--- /dev/null
+++ b/pkgs/tools/networking/sproxy/default.nix
@@ -0,0 +1,36 @@
+{ cabal, aeson, attoparsec, caseInsensitive, certificate
+, concurrentExtra, cryptoRandom, curl, dataDefault, hslogger, hspec
+, HTTP, httpTypes, interpolatedstringPerl6, mtl, network
+, optparseApplicative, postgresqlSimple, safe, SHA, split
+, stringConversions, time, tls, unorderedContainers, utf8String
+, x509, yaml, fetchurl
+}:
+
+cabal.mkDerivation (self: {
+  pname = "sproxy";
+  version = "0.7.4";
+  src = fetchurl {
+    url = "https://github.com/zalora/sproxy/archive/0.7.4.tar.gz";
+    sha256 = "1zlsln0ihg7p8jk5gdvm9as6gk4fs8vaa547iq2yvna4c1wb4amr";
+  };
+  isLibrary = false;
+  isExecutable = true;
+  buildDepends = [
+    aeson attoparsec caseInsensitive certificate concurrentExtra
+    cryptoRandom curl dataDefault hslogger HTTP httpTypes
+    interpolatedstringPerl6 mtl network optparseApplicative
+    postgresqlSimple safe SHA split stringConversions time tls
+    unorderedContainers utf8String x509 yaml
+  ];
+  testDepends = [
+    aeson attoparsec caseInsensitive certificate concurrentExtra
+    cryptoRandom curl dataDefault hslogger hspec HTTP httpTypes
+    interpolatedstringPerl6 mtl network optparseApplicative
+    postgresqlSimple safe SHA split stringConversions time tls
+    unorderedContainers utf8String x509 yaml
+  ];
+  meta = {
+    license = self.stdenv.lib.licenses.mit;
+    platforms = self.ghc.meta.platforms;
+  };
+})