summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorTobias Pflug <tobias.pflug@holidaycheck.com>2018-02-03 22:52:20 +0100
committerTobias Pflug <tobias.pflug@holidaycheck.com>2018-02-03 22:54:18 +0100
commit32d4b018a7a7cb9b20b0f3cb5384c61670d0eae5 (patch)
tree3a1918b9095b1fe5010339e34535ff7e4d12e5b1 /pkgs/tools
parente193d8674bc9c0a6ddea311f6d0a50b851747e6c (diff)
downloadnixlib-32d4b018a7a7cb9b20b0f3cb5384c61670d0eae5.tar
nixlib-32d4b018a7a7cb9b20b0f3cb5384c61670d0eae5.tar.gz
nixlib-32d4b018a7a7cb9b20b0f3cb5384c61670d0eae5.tar.bz2
nixlib-32d4b018a7a7cb9b20b0f3cb5384c61670d0eae5.tar.lz
nixlib-32d4b018a7a7cb9b20b0f3cb5384c61670d0eae5.tar.xz
nixlib-32d4b018a7a7cb9b20b0f3cb5384c61670d0eae5.tar.zst
nixlib-32d4b018a7a7cb9b20b0f3cb5384c61670d0eae5.zip
grobi: init at 0.3.0
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/X11/grobi/default.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/pkgs/tools/X11/grobi/default.nix b/pkgs/tools/X11/grobi/default.nix
new file mode 100644
index 000000000000..42f3bbdb0194
--- /dev/null
+++ b/pkgs/tools/X11/grobi/default.nix
@@ -0,0 +1,22 @@
+{ stdenv, fetchFromGitHub, buildGoPackage }:
+
+buildGoPackage rec {
+  version = "0.3.0";
+  name = "grobi-${version}";
+
+  goPackagePath = "github.com/fd0/grobi";
+
+  src = fetchFromGitHub {
+    rev = "78a0639ffad765933a5233a1c94d2626e24277b8";
+    owner = "fd0";
+    repo = "grobi";
+    sha256 = "16q7vnhb1p6ds561832sfdszvlafww67bjn3lc0d18v7lyak2l3i";
+  };
+
+   meta = with stdenv.lib; {
+    homepage = https://github.com/fd0/grobi;
+    description = "Automatically configure monitors/outputs for Xorg via RANDR";
+    license = with licenses; [ bsd2 ];
+    platforms   = platforms.linux;
+  };
+}