summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorVladimír Čunát <vcunat@gmail.com>2017-06-11 08:58:57 +0200
committerVladimír Čunát <vcunat@gmail.com>2017-06-11 09:01:08 +0200
commit32916ab1de83642611ea900bdeb951ffb1859343 (patch)
tree5097471fb992bb9e8fdb5090dcaec31e6f7ace79 /pkgs/tools
parentd373b7b61af6ad727e5ce40ecd2aacd997271a86 (diff)
parentcb9f953c923eb9fdb1f23458bbc43460f269c5c7 (diff)
downloadnixlib-32916ab1de83642611ea900bdeb951ffb1859343.tar
nixlib-32916ab1de83642611ea900bdeb951ffb1859343.tar.gz
nixlib-32916ab1de83642611ea900bdeb951ffb1859343.tar.bz2
nixlib-32916ab1de83642611ea900bdeb951ffb1859343.tar.lz
nixlib-32916ab1de83642611ea900bdeb951ffb1859343.tar.xz
nixlib-32916ab1de83642611ea900bdeb951ffb1859343.tar.zst
nixlib-32916ab1de83642611ea900bdeb951ffb1859343.zip
Merge older staging
Enough rebuilds have finished on Hydra now.
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/networking/openssh/default.nix7
-rw-r--r--pkgs/tools/system/vboot_reference/default.nix9
2 files changed, 11 insertions, 5 deletions
diff --git a/pkgs/tools/networking/openssh/default.nix b/pkgs/tools/networking/openssh/default.nix
index 0bcb0baaab8b..aaef2723da0c 100644
--- a/pkgs/tools/networking/openssh/default.nix
+++ b/pkgs/tools/networking/openssh/default.nix
@@ -49,6 +49,13 @@ stdenv.mkDerivation rec {
     ]
     ++ optional withGssapiPatches gssapiSrc;
 
+  postPatch =
+    # On Hydra this makes installation fail (sometimes?),
+    # and nix store doesn't allow such fancy permission bits anyway.
+    ''
+      substituteInPlace Makefile.in --replace '$(INSTALL) -m 4711' '$(INSTALL) -m 0711'
+    '';
+
   buildInputs = [ zlib openssl libedit pkgconfig pam ]
     ++ optional withKerberos kerberos
     ++ optional hpnSupport autoreconfHook;
diff --git a/pkgs/tools/system/vboot_reference/default.nix b/pkgs/tools/system/vboot_reference/default.nix
index 3d4f99fc1f0b..a9a034ebde91 100644
--- a/pkgs/tools/system/vboot_reference/default.nix
+++ b/pkgs/tools/system/vboot_reference/default.nix
@@ -12,11 +12,10 @@ stdenv.mkDerivation rec {
     sha256 = "14d3a93ha5k4al4ib43nyn1ppx7kgb12xw6mkflhx8nxmx8827nc";
   };
 
-  buildInputs = [ pkgconfig openssl stdenv.cc.libc.static ] ++
-                (if libuuid == null
-                 then []
-                 else [ (stdenv.lib.overrideDerivation libuuid
-                          (args: { configureFlags = args.configureFlags + " --enable-static"; })) ]);
+  buildInputs = [ pkgconfig openssl stdenv.cc.libc.static ]
+    ++ stdenv.lib.optional (libuuid != null)
+         (libuuid.overrideAttrs (attrs:
+           { configureFlags = attrs.configureFlags ++ [ "--enable-static" ]; }));
 
   arch = if stdenv.system == "x86_64-linux" then "x86_64"
     else if stdenv.system == "i686-linux" then "x86"