summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorEvgeny Egorochkin <phreedom@yandex.ru>2013-08-10 20:07:36 +0300
committerEvgeny Egorochkin <phreedom@yandex.ru>2013-08-10 20:09:18 +0300
commit3065a7686bfb247b0ddca9967a38ffdb6ed57b32 (patch)
treeb68cf0223b191acd86cfa64c0d9de6353c44fc39 /pkgs/tools
parent15637cf207bf8fe693e4de1f4c8ee73a6d664898 (diff)
downloadnixlib-3065a7686bfb247b0ddca9967a38ffdb6ed57b32.tar
nixlib-3065a7686bfb247b0ddca9967a38ffdb6ed57b32.tar.gz
nixlib-3065a7686bfb247b0ddca9967a38ffdb6ed57b32.tar.bz2
nixlib-3065a7686bfb247b0ddca9967a38ffdb6ed57b32.tar.lz
nixlib-3065a7686bfb247b0ddca9967a38ffdb6ed57b32.tar.xz
nixlib-3065a7686bfb247b0ddca9967a38ffdb6ed57b32.tar.zst
nixlib-3065a7686bfb247b0ddca9967a38ffdb6ed57b32.zip
torbutton: package version 1.6.1
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/security/torbutton/default.nix29
1 files changed, 29 insertions, 0 deletions
diff --git a/pkgs/tools/security/torbutton/default.nix b/pkgs/tools/security/torbutton/default.nix
new file mode 100644
index 000000000000..348d96b00247
--- /dev/null
+++ b/pkgs/tools/security/torbutton/default.nix
@@ -0,0 +1,29 @@
+{ stdenv, fetchgit, zip }:
+stdenv.mkDerivation rec {
+
+  name = "torbutton-${version}.xpi";
+  version = "1.6.1";
+
+  src = fetchgit {
+    url = https://git.torproject.org/torbutton.git;
+    rev = "refs/tags/${version}";
+    sha256 = "0ypzrl8nhckrgh45rcwsjds1jnzz3w5nr09b926a4h3a5njammlv";
+  };
+
+  buildInputs = [ zip ];
+
+  buildPhase = ''
+    mkdir pkg
+    ./makexpi.sh
+  '';
+
+  installPhase = "cat pkg/*.xpi > $out";
+
+  meta = with stdenv.lib; {
+    homepage = https://www.torproject.org/torbutton/;
+    description = "the component in Tor Browser Bundle that takes care of application-level security and privacy concerns in Firefox. To keep you safe, Torbutton disables many types of active content.";
+    license = licenses.mit;
+    maintainers = [ maintainers.phreedom ];
+    platforms = platforms.linux;
+  };
+}