summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorWilliam A. Kennington III <william@wkennington.com>2015-10-02 12:41:09 -0700
committerWilliam A. Kennington III <william@wkennington.com>2015-10-02 12:41:09 -0700
commit2ef6508c7f187e1b8433f9936b98b79bee6ed31c (patch)
tree80b19d8098b5a1d93c8bca057438b5d0ed35f704 /pkgs/tools
parented71860928c2c645d388ef55b51623c42b948596 (diff)
parent423613129505299ee0779863cd759c0afb31ce24 (diff)
downloadnixlib-2ef6508c7f187e1b8433f9936b98b79bee6ed31c.tar
nixlib-2ef6508c7f187e1b8433f9936b98b79bee6ed31c.tar.gz
nixlib-2ef6508c7f187e1b8433f9936b98b79bee6ed31c.tar.bz2
nixlib-2ef6508c7f187e1b8433f9936b98b79bee6ed31c.tar.lz
nixlib-2ef6508c7f187e1b8433f9936b98b79bee6ed31c.tar.xz
nixlib-2ef6508c7f187e1b8433f9936b98b79bee6ed31c.tar.zst
nixlib-2ef6508c7f187e1b8433f9936b98b79bee6ed31c.zip
Merge branch 'master.upstream' into staging.post-15.06
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/filesystems/duff/default.nix19
-rw-r--r--pkgs/tools/graphics/enblend-enfuse/default.nix10
-rw-r--r--pkgs/tools/misc/heatseeker/default.nix28
3 files changed, 43 insertions, 14 deletions
diff --git a/pkgs/tools/filesystems/duff/default.nix b/pkgs/tools/filesystems/duff/default.nix
index 310153341669..1c4d068c4c13 100644
--- a/pkgs/tools/filesystems/duff/default.nix
+++ b/pkgs/tools/filesystems/duff/default.nix
@@ -1,12 +1,14 @@
 { stdenv, fetchFromGitHub, autoreconfHook, gettext }:
 
-let version = "0.5.2"; in
+# The last release (0.5.2) is more than 2 years old and lacks features like -D,
+# limiting its usefulness. Upstream appears comatose if not dead.
+let version = "2014-07-03"; in
 stdenv.mkDerivation {
   name = "duff-${version}";
 
   src = fetchFromGitHub {
-    sha256 = "0yfm910wjj6z0f0cg68x59ykf4ql5m49apzy8sra00f8kv4lpn53";
-    rev = version;
+    sha256 = "1k2dx38pjzc5d624vw1cs5ipj9fprsm5vqv55agksc29m63lswnx";
+    rev = "f26d4837768b062a3f98fa075c791d9c8a0bb75c";
     repo = "duff";
     owner = "elmindreda";
   };
@@ -14,10 +16,6 @@ stdenv.mkDerivation {
   nativeBuildInputs = [ autoreconfHook gettext ];
 
   preAutoreconf = ''
-    # duff is currently badly packaged, requiring us to do extra work here that
-    # should be done upstream. If that is ever fixed, this entire phase can be
-    # removed along with all buildInputs.
-
     # gettexttize rightly refuses to run non-interactively:
     cp ${gettext}/bin/gettextize .
     substituteInPlace gettextize \
@@ -30,14 +28,15 @@ stdenv.mkDerivation {
   enableParallelBuilding = true;
 
   meta = with stdenv.lib; {
+    inherit version;
     description = "Quickly find duplicate files";
-    homepage = http://duff.dreda.org/;
-    license = licenses.zlib;
     longDescription = ''
       Duff is a Unix command-line utility for quickly finding duplicates in
       a given set of files.
     '';
+    homepage = http://duff.dreda.org/;
+    license = licenses.zlib;
+    platforms = platforms.all;
     maintainers = with maintainers; [ nckx ];
-    platforms = with platforms; all;
   };
 }
diff --git a/pkgs/tools/graphics/enblend-enfuse/default.nix b/pkgs/tools/graphics/enblend-enfuse/default.nix
index 6b65d3df0d3f..c967b73001c7 100644
--- a/pkgs/tools/graphics/enblend-enfuse/default.nix
+++ b/pkgs/tools/graphics/enblend-enfuse/default.nix
@@ -1,22 +1,24 @@
 { stdenv, fetchurl
 , boost, freeglut, glew, gsl, lcms2, libpng, libtiff, libxmi, mesa, vigra
-, pkgconfig, perl }:
+, help2man, pkgconfig, perl }:
 
+let version = "4.1.4"; in
 stdenv.mkDerivation rec {
-  name = "enblend-enfuse-4.1.3";
+  name = "enblend-enfuse-${version}";
 
   src = fetchurl {
     url = "mirror://sourceforge/enblend/${name}.tar.gz";
-    sha256 = "1b7r1nnwaind0344ckwggy0ghl0ipbk9jzylsxcjfl05rnasw00w";
+    sha256 = "0208x01i129hqylmy6jh3krwdac47mx6fi8xccjm9h35c18c7xl5";
   };
 
   buildInputs = [ boost freeglut glew gsl lcms2 libpng libtiff libxmi mesa vigra ];
 
-  nativeBuildInputs = [ perl pkgconfig ];
+  nativeBuildInputs = [ help2man perl pkgconfig ];
 
   enableParallelBuilding = true;
 
   meta = {
+    inherit version;
     homepage = http://enblend.sourceforge.net/;
     description = "Blends away the seams in a panoramic image mosaic using a multiresolution spline";
     license = stdenv.lib.licenses.gpl2;
diff --git a/pkgs/tools/misc/heatseeker/default.nix b/pkgs/tools/misc/heatseeker/default.nix
new file mode 100644
index 000000000000..0d85554c347d
--- /dev/null
+++ b/pkgs/tools/misc/heatseeker/default.nix
@@ -0,0 +1,28 @@
+{ stdenv, fetchFromGitHub, rustPlatform }:
+
+with rustPlatform;
+
+buildRustPackage rec {
+  name = "heatseeker-${version}";
+  version = "1.3.0";
+
+  depsSha256 = "03jap7myf85xgx9270sws8x57nl04a1wx8szrk9qx24s9vnnjcnh";
+
+  src = fetchFromGitHub {
+    owner = "rschmitt";
+    repo = "heatseeker";
+    rev = "v${version}";
+    sha256 = "1xdvwgmh9lwv82hv1qg82bjv2iplnvva6lzbg7dyhbszhv7rhkbl";
+  };
+  
+  # some tests require a tty, this variable turns them off for Travis CI,
+  # which we can also make use of
+  TRAVIS= "true";
+
+  meta = with stdenv.lib; {
+    description = "A general-purpose fuzzy selector";
+    homepage = https://github.com/rschmitt/heatseeker;
+    license = stdenv.lib.licenses.mit;
+    maintainers = [ maintainers.michaelpj ];
+  };
+}