summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorJörg Thalheim <Mic92@users.noreply.github.com>2018-02-09 17:01:06 +0000
committerGitHub <noreply@github.com>2018-02-09 17:01:06 +0000
commit2e864797906cbaed3017c6cf79bd610a22732b67 (patch)
tree3f03a68907c9f2eee65c9eb277d276b5c849d891 /pkgs/tools
parent5b247f741d9caa6a6b82a44a2629c0d8325d0130 (diff)
parent9ccbb2aa37023e834cc5b6bd0e0262e377a23df8 (diff)
downloadnixlib-2e864797906cbaed3017c6cf79bd610a22732b67.tar
nixlib-2e864797906cbaed3017c6cf79bd610a22732b67.tar.gz
nixlib-2e864797906cbaed3017c6cf79bd610a22732b67.tar.bz2
nixlib-2e864797906cbaed3017c6cf79bd610a22732b67.tar.lz
nixlib-2e864797906cbaed3017c6cf79bd610a22732b67.tar.xz
nixlib-2e864797906cbaed3017c6cf79bd610a22732b67.tar.zst
nixlib-2e864797906cbaed3017c6cf79bd610a22732b67.zip
Merge pull request #34627 from dtzWill/update/rhash-git
rhash: 1.3.3 -> 2018-02-05
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/security/rhash/darwin.patch38
-rw-r--r--pkgs/tools/security/rhash/default.nix33
2 files changed, 12 insertions, 59 deletions
diff --git a/pkgs/tools/security/rhash/darwin.patch b/pkgs/tools/security/rhash/darwin.patch
deleted file mode 100644
index 76ad8fe9abd9..000000000000
--- a/pkgs/tools/security/rhash/darwin.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-diff --git a/Makefile b/Makefile
-index e40dbc3..e198b93 100644
---- a/Makefile
-+++ b/Makefile
-@@ -17,7 +17,7 @@ ALLCFLAGS = -pipe $(CFLAGS) $(ADDCFLAGS) \
-   -Wbad-function-cast -Wmissing-prototypes -Wmissing-declarations
- LDLIBRHASH = -Llibrhash -lrhash
- ALLLDFLAGS = $(LDLIBRHASH) $(LDFLAGS) $(ADDLDFLAGS)
--SHAREDLIB  = librhash/librhash.so.0
-+SHAREDLIB  = librhash/librhash.0.dylib
- SHRDLFLAGS = $(LDFLAGS) $(ADDLDFLAGS)
- HEADERS = calc_sums.h hash_print.h common_func.h hash_update.h file_mask.h file_set.h find_file.h hash_check.h output.h parse_cmdline.h rhash_main.h win_utils.h version.h
- SOURCES = calc_sums.c hash_print.c common_func.c hash_update.c file_mask.c file_set.c find_file.c hash_check.c output.c parse_cmdline.c rhash_main.c win_utils.c
-diff --git a/librhash/Makefile b/librhash/Makefile
-index 2f9bcc9..0c5aaad 100644
---- a/librhash/Makefile
-+++ b/librhash/Makefile
-@@ -28,8 +28,8 @@ PREFIX  = /usr/local
- INCDIR  = $(PREFIX)/include
- LIBDIR  = $(PREFIX)/lib
- LIBRARY = librhash.a
--SONAME  = librhash.so.0
--SOLINK  = librhash.so
-+SONAME  = librhash.0.dylib
-+SOLINK  = librhash.dylib
- TEST_TARGET = test_hashes
- TEST_SHARED = test_shared
- # Set variables according to GNU coding standard
-@@ -182,8 +182,7 @@ test-dll: $(DLLNAME) test_hashes.o
- 
- # shared and static libraries
- $(SONAME): $(SOURCES)
--	sed -n '1s/.*/{ global:/p; s/^RHASH_API.* \([a-z0-9_]\+\)(.*/  \1;/p; $$s/.*/local: *; };/p' $(SO_HEADERS) > exports.sym
--	$(CC) -fpic $(ALLCFLAGS) -shared $(SOURCES) -Wl,--version-script,exports.sym,-soname,$(SONAME) $(LIBLDFLAGS) -o $@
-+	$(CC) -fpic $(ALLCFLAGS) -dynamiclib $(SOURCES) $(LIBLDFLAGS) -Wl,-install_name,$(PREFIX)/lib/$@ -o $@
- 	ln -s $(SONAME) $(SOLINK)
- # use 'nm -Cg --defined-only $@' to view exported symbols
- 
diff --git a/pkgs/tools/security/rhash/default.nix b/pkgs/tools/security/rhash/default.nix
index 68c3edc4cd25..485b34cff88d 100644
--- a/pkgs/tools/security/rhash/default.nix
+++ b/pkgs/tools/security/rhash/default.nix
@@ -1,32 +1,23 @@
-{ stdenv, fetchurl }:
+{ stdenv, fetchFromGitHub, which }:
 
 stdenv.mkDerivation rec {
-  version = "1.3.3";
+  version = "2018-02-05";
   name = "rhash-${version}";
 
-  src = fetchurl {
-    url = "mirror://sourceforge/rhash/${name}-src.tar.gz";
-    sha1 = "0981bdc98ba7ef923b1a6cd7fd8bb0374cff632e";
-    sha256 = "0nii6p4m2x8rkaf8r6smgfwb1q4hpf117kkg64yr6gyqgdchnljv";
+  src = fetchFromGitHub {
+    owner = "rhash";
+    repo = "RHash";
+    rev = "cc26d54ff5df0f692907a5e3132a5eeca559ed61";
+    sha256 = "1ldagp931lmxxpyvsb9rrar4iqwmv94m6lfjzkbkshpmk3p5ng7h";
   };
 
-  patches = stdenv.lib.optional stdenv.isDarwin ./darwin.patch;
+  nativeBuildInputs = [ which ];
 
-  installFlags = [ "DESTDIR=$(out)" "PREFIX=/" ];
+  # configure script is not autotools-based, doesn't support these options
+  configurePlatforms = [ ];
 
-  # we build the static library because of two makefile bugs
-  # * .h files installed for static library target only
-  # * .so.0 -> .so link only created in the static library install target
-  buildPhase = ''
-    make lib-shared lib-static build-shared CC=$CC AR=$AR PREFIX=$out
-  '';
-
-  # we don't actually want the static library, so we remove it after it
-  # gets installed
-  installPhase = ''
-    make DESTDIR="$out" PREFIX="/" install-shared install-lib-shared install-lib-static
-    rm $out/lib/librhash.a
-  '';
+  installTargets = [ "install" "install-lib-shared" "install-lib-so-link" ];
+  postInstall = "make -C librhash install-headers";
 
   meta = with stdenv.lib; {
     homepage = http://rhash.anz.ru;