summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorCasey Ransom <casey@dailykos.com>2018-07-26 11:38:26 -0400
committerCasey Ransom <casey@dailykos.com>2018-08-16 10:42:47 -0400
commit27d4088eb489b6137031cc8b693b22f070b3aef1 (patch)
tree24ce5dae8875c15aeae118232d47d80643d115fa /pkgs/tools
parentc61b20396f23c56db602044010d28120dca7626e (diff)
downloadnixlib-27d4088eb489b6137031cc8b693b22f070b3aef1.tar
nixlib-27d4088eb489b6137031cc8b693b22f070b3aef1.tar.gz
nixlib-27d4088eb489b6137031cc8b693b22f070b3aef1.tar.bz2
nixlib-27d4088eb489b6137031cc8b693b22f070b3aef1.tar.lz
nixlib-27d4088eb489b6137031cc8b693b22f070b3aef1.tar.xz
nixlib-27d4088eb489b6137031cc8b693b22f070b3aef1.tar.zst
nixlib-27d4088eb489b6137031cc8b693b22f070b3aef1.zip
cli53: 0.4.4 -> 0.8.12
This is bigger change than the version would imply as the author has
rewritten in Go and no longer supports the Python app.
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/admin/cli53/default.nix34
-rw-r--r--pkgs/tools/admin/cli53/deps.nix92
2 files changed, 103 insertions, 23 deletions
diff --git a/pkgs/tools/admin/cli53/default.nix b/pkgs/tools/admin/cli53/default.nix
index e70a7ba9b50c..6fe568966e9f 100644
--- a/pkgs/tools/admin/cli53/default.nix
+++ b/pkgs/tools/admin/cli53/default.nix
@@ -1,30 +1,20 @@
-{ lib, python2, fetchurl }:
+# This file was generated by https://github.com/kamilchm/go2nix v2.0-dev
+{ lib, stdenv, buildGoPackage, fetchFromGitHub }:
 
-python2.pkgs.buildPythonApplication rec {
+buildGoPackage rec {
   name = "cli53-${version}";
-  version = "0.4.4";
+  version = "0.8.12";
 
-  src = fetchurl {
-    url = "mirror://pypi/c/cli53/${name}.tar.gz";
-    sha256 = "0s9jzigq6a16m2c3qklssx2lz16cf13g5zh80vh24kxazaxqzbig";
-  };
-
-  postPatch = ''
-    substituteInPlace setup.py --replace "'argparse', " ""
-  '';
+  goPackagePath = "github.com/barnybug/cli53";
 
-  checkPhase = ''
-    ${python2.interpreter} -m unittest discover -s tests
-  '';
-
-  # Tests do not function
-  doCheck = false;
+  src = fetchFromGitHub {
+    owner = "barnybug";
+    repo = "cli53";
+    rev = "2624c7c4b38a33cdbd166dad1d3e512830f453e4";
+    sha256 = "0bhczmzrgf7ypnhhzdrgnvg8cw8ch1x1d0cgajc5kklq9ixv9ygi";
+  };
 
-  propagatedBuildInputs = with python2.pkgs; [
-    argparse
-    boto
-    dnspython
-  ];
+  goDeps = ./deps.nix;
 
   meta = with lib; {
     description = "CLI tool for the Amazon Route 53 DNS service";
diff --git a/pkgs/tools/admin/cli53/deps.nix b/pkgs/tools/admin/cli53/deps.nix
index 0cb0360e499d..4742bc00851b 100644
--- a/pkgs/tools/admin/cli53/deps.nix
+++ b/pkgs/tools/admin/cli53/deps.nix
@@ -1,3 +1,93 @@
-# This file was generated by https://github.com/kamilchm/go2nix v1.2.0
+# This file was generated by https://github.com/kamilchm/go2nix v2.0-dev
 [
+  {
+    goPackagePath = "github.com/aws/aws-sdk-go";
+    fetch = {
+      type = "git";
+      url = "https://github.com/aws/aws-sdk-go";
+      rev = "3e7014382cdc91695381614d0110a3cff997ba72";
+      sha256 = "1xnjhmb31k63k13aiiiispc7vkgnlxkbihslwwfsjc7b86vrllm5";
+    };
+  }
+  {
+    goPackagePath = "github.com/davecgh/go-spew";
+    fetch = {
+      type = "git";
+      url = "https://github.com/davecgh/go-spew";
+      rev = "346938d642f2ec3594ed81d874461961cd0faa76";
+      sha256 = "0d4jfmak5p6lb7n2r6yvf5p1zcw0l8j74kn55ghvr7zr7b7axm6c";
+    };
+  }
+  {
+    goPackagePath = "github.com/go-ini/ini";
+    fetch = {
+      type = "git";
+      url = "https://github.com/go-ini/ini";
+      rev = "20b96f641a5ea98f2f8619ff4f3e061cff4833bd";
+      sha256 = "0mp18hlhnazg3sd02fhv88kbbipmhcrkb6n8imq8gk2dvmxk64ch";
+    };
+  }
+  {
+    goPackagePath = "github.com/gucumber/gucumber";
+    fetch = {
+      type = "git";
+      url = "https://github.com/gucumber/gucumber";
+      rev = "71608e2f6e76fd4da5b09a376aeec7a5c0b5edbc";
+      sha256 = "1h1d9j515v1nyqsyb73v4ahlvm9n6z7hgl2ld8dryr4sw8q7ybw3";
+    };
+  }
+  {
+    goPackagePath = "github.com/jmespath/go-jmespath";
+    fetch = {
+      type = "git";
+      url = "https://github.com/jmespath/go-jmespath";
+      rev = "0b12d6b5";
+      sha256 = "1vv6hph8j6xgv7gwl9vvhlsaaqsm22sxxqmgmldi4v11783pc1ld";
+    };
+  }
+  {
+    goPackagePath = "github.com/miekg/dns";
+    fetch = {
+      type = "git";
+      url = "https://github.com/miekg/dns";
+      rev = "e4205768578dc90c2669e75a2f8a8bf77e3083a4";
+      sha256 = "0247qcc9i41wrm73ivqs2wvy3vi3nb44m3nh27lnhd4a0ilir6wv";
+    };
+  }
+  {
+    goPackagePath = "github.com/pmezard/go-difflib";
+    fetch = {
+      type = "git";
+      url = "https://github.com/pmezard/go-difflib";
+      rev = "792786c7400a136282c1664665ae0a8db921c6c2";
+      sha256 = "0c1cn55m4rypmscgf0rrb88pn58j3ysvc2d0432dp3c6fqg6cnzw";
+    };
+  }
+  {
+    goPackagePath = "github.com/shiena/ansicolor";
+    fetch = {
+      type = "git";
+      url = "https://github.com/shiena/ansicolor";
+      rev = "a422bbe96644373c5753384a59d678f7d261ff10";
+      sha256 = "1dcn8a9z6a5dxa2m3fkppnajcls8lanbl38qggkf646yi5qsk1hc";
+    };
+  }
+  {
+    goPackagePath = "github.com/stretchr/testify";
+    fetch = {
+      type = "git";
+      url = "https://github.com/stretchr/testify";
+      rev = "12b6f73e6084dad08a7c6e575284b177ecafbc71";
+      sha256 = "01f80s0q64pw5drfgqwwk1wfwwkvd2lhbs56lhhkff4ni83k73fd";
+    };
+  }
+  {
+    goPackagePath = "github.com/urfave/cli";
+    fetch = {
+      type = "git";
+      url = "https://github.com/urfave/cli";
+      rev = "cfb38830724cc34fedffe9a2a29fb54fa9169cd1";
+      sha256 = "0y6f4sbzkiiwrxbl15biivj8c7qwxnvm3zl2dd3mw4wzg4x10ygj";
+    };
+  }
 ]