summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorOrivej Desh <orivej@gmx.fr>2017-11-01 04:32:21 +0000
committerGitHub <noreply@github.com>2017-11-01 04:32:21 +0000
commit26e4f6f4f8a0466432e4eaa750076c96e7a65ca5 (patch)
tree84ec1f0af37ac1e59ca3134477458ac10e56d885 /pkgs/tools
parent73fe83206e71dd5c19b11972cd07467547f10f3e (diff)
parent7bd64e3dee5c687030213c79601ea7da06528765 (diff)
downloadnixlib-26e4f6f4f8a0466432e4eaa750076c96e7a65ca5.tar
nixlib-26e4f6f4f8a0466432e4eaa750076c96e7a65ca5.tar.gz
nixlib-26e4f6f4f8a0466432e4eaa750076c96e7a65ca5.tar.bz2
nixlib-26e4f6f4f8a0466432e4eaa750076c96e7a65ca5.tar.lz
nixlib-26e4f6f4f8a0466432e4eaa750076c96e7a65ca5.tar.xz
nixlib-26e4f6f4f8a0466432e4eaa750076c96e7a65ca5.tar.zst
nixlib-26e4f6f4f8a0466432e4eaa750076c96e7a65ca5.zip
Merge pull request #30980 from wizeman/u/fix-cjdns-hash
cjdns: fix hash
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/networking/cjdns/default.nix10
1 files changed, 6 insertions, 4 deletions
diff --git a/pkgs/tools/networking/cjdns/default.nix b/pkgs/tools/networking/cjdns/default.nix
index 11f65ea82b03..d5819639fa2c 100644
--- a/pkgs/tools/networking/cjdns/default.nix
+++ b/pkgs/tools/networking/cjdns/default.nix
@@ -1,12 +1,14 @@
-{ stdenv, fetchurl, fetchpatch, nodejs, which, python27, utillinux }:
+{ stdenv, fetchFromGitHub, nodejs, which, python27, utillinux }:
 
 let version = "20"; in
 stdenv.mkDerivation {
   name = "cjdns-"+version;
 
-  src = fetchurl {
-    url = "https://github.com/cjdelisle/cjdns/archive/cjdns-v${version}.tar.gz";
-    sha256 = "1dyqxi9l2pmrgm16a161909rg3vfzvib40frr7p6ddpk8yfh5888";
+  src = fetchFromGitHub {
+    owner = "cjdelisle";
+    repo = "cjdns";
+    rev = "cjdns-v${version}";
+    sha256 = "0gqcspiz1n0j711vwq807cy456dkcf03r376l04qc92173g2fzrx";
   };
 
   buildInputs = [ which python27 nodejs ] ++