summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorIngo Blechschmidt <iblech@web.de>2018-10-25 19:04:14 +0200
committerRenaud <c0bw3b@users.noreply.github.com>2018-10-25 19:04:14 +0200
commit2595be06af5c174aae5abee4f07bb050f88c13f7 (patch)
tree3cc1d57f165f7911c44f3e7cc41fd25293b5a59d /pkgs/tools
parent1780ecb041bd46772f89e64310f0e46cbd6e8f30 (diff)
downloadnixlib-2595be06af5c174aae5abee4f07bb050f88c13f7.tar
nixlib-2595be06af5c174aae5abee4f07bb050f88c13f7.tar.gz
nixlib-2595be06af5c174aae5abee4f07bb050f88c13f7.tar.bz2
nixlib-2595be06af5c174aae5abee4f07bb050f88c13f7.tar.lz
nixlib-2595be06af5c174aae5abee4f07bb050f88c13f7.tar.xz
nixlib-2595be06af5c174aae5abee4f07bb050f88c13f7.tar.zst
nixlib-2595be06af5c174aae5abee4f07bb050f88c13f7.zip
tikzit: init at 2.0 (#48479)
* tikzit: init at 2.0

* tikzit: Parallel building and qualification
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/typesetting/tikzit/default.nix31
1 files changed, 31 insertions, 0 deletions
diff --git a/pkgs/tools/typesetting/tikzit/default.nix b/pkgs/tools/typesetting/tikzit/default.nix
new file mode 100644
index 000000000000..23d8093606be
--- /dev/null
+++ b/pkgs/tools/typesetting/tikzit/default.nix
@@ -0,0 +1,31 @@
+{ stdenv, fetchFromGitHub, qmake, qttools, qtbase, flex, bison }:
+
+stdenv.mkDerivation rec {
+  name = "tikzit-${version}";
+  version = "2.0";
+
+  src = fetchFromGitHub {
+    owner = "tikzit";
+    repo = "tikzit";
+    rev = "v${version}";
+    sha256 = "0fwxr9rc9vmw2jzpj084rygzyhp4xm3vm737668az600ln2scyad";
+  };
+
+  nativeBuildInputs = [ qmake qttools flex bison ];
+  buildInputs = [ qtbase ];
+
+  enableParallelBuilding = true;
+
+  meta = with stdenv.lib; {
+    description = "A graphical tool for rapidly creating graphs and diagrams using PGF/TikZ";
+    longDescription = ''
+      TikZiT is a simple GUI editor for graphs and string diagrams.
+      Its native file format is a subset of PGF/TikZ, which means TikZiT files
+      can be included directly in papers typeset using LaTeX.
+    '';
+    homepage = https://tikzit.github.io/;
+    license = licenses.gpl3Plus;
+    platforms = platforms.all;
+    maintainers = [ maintainers.iblech maintainers.mgttlinger ];
+  };
+}