summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorJörg Thalheim <Mic92@users.noreply.github.com>2017-08-01 08:05:37 +0100
committerGitHub <noreply@github.com>2017-08-01 08:05:37 +0100
commit22f380c5f9eefdbb2303e9e8a96ebff3fcd35888 (patch)
tree9018e988cbb3444cf9660a804c52ec03e5a35620 /pkgs/tools
parentfd647dc0cf5b989aea84c14adcecff10d9dff536 (diff)
parent925a4ba4605a7c5e8fd8e17aaabddff42a9750bc (diff)
downloadnixlib-22f380c5f9eefdbb2303e9e8a96ebff3fcd35888.tar
nixlib-22f380c5f9eefdbb2303e9e8a96ebff3fcd35888.tar.gz
nixlib-22f380c5f9eefdbb2303e9e8a96ebff3fcd35888.tar.bz2
nixlib-22f380c5f9eefdbb2303e9e8a96ebff3fcd35888.tar.lz
nixlib-22f380c5f9eefdbb2303e9e8a96ebff3fcd35888.tar.xz
nixlib-22f380c5f9eefdbb2303e9e8a96ebff3fcd35888.tar.zst
nixlib-22f380c5f9eefdbb2303e9e8a96ebff3fcd35888.zip
Merge pull request #27783 from 8573/8573/pkg/add/rust/fd-sharkdp/1
fd: init at 2.0.0
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/misc/fd/default.nix28
1 files changed, 28 insertions, 0 deletions
diff --git a/pkgs/tools/misc/fd/default.nix b/pkgs/tools/misc/fd/default.nix
new file mode 100644
index 000000000000..763ca668d181
--- /dev/null
+++ b/pkgs/tools/misc/fd/default.nix
@@ -0,0 +1,28 @@
+{ stdenv, fetchFromGitHub, rustPlatform }:
+
+rustPlatform.buildRustPackage rec {
+  name = "fd-${version}";
+  version = "2.0.0";
+
+  src = fetchFromGitHub {
+    owner = "sharkdp";
+    repo = "fd";
+    rev = "v${version}";
+    sha256 = "1xs4y9zf5m0ykl95787jv98xg0a60gkcyyh7kg7qg4xrcgf4qz4j";
+  };
+
+  depsSha256 = "1hxf3j4584jgpwrwykx6yil6q6ka9l81qvx6zrbprdxk3pslp049";
+
+  meta = {
+    description = "A simple, fast and user-friendly alternative to find";
+    longDescription = ''
+      `fd` is a simple, fast and user-friendly alternative to `find`.
+
+      While it does not seek to mirror all of `find`'s powerful functionality,
+      it provides sensible (opinionated) defaults for 80% of the use cases.
+    '';
+    homepage = "https://github.com/sharkdp/fd";
+    license = stdenv.lib.licenses.mit;
+    platforms = stdenv.lib.platforms.all;
+  };
+}