summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorArseniy Seroka <jagajaga@users.noreply.github.com>2016-01-09 19:13:37 +0300
committerArseniy Seroka <jagajaga@users.noreply.github.com>2016-01-09 19:13:37 +0300
commit1ef51c8eb092cf112b4022a77148a658806273c2 (patch)
tree7b362fcf4bcb8ef75aaa9f28ae9e07177c5ac09a /pkgs/tools
parent134e5525a214daca8172b6a40d13560ea7128332 (diff)
parent154040ab1c7a854c11e2a92e7c2991f12fd6fcf1 (diff)
downloadnixlib-1ef51c8eb092cf112b4022a77148a658806273c2.tar
nixlib-1ef51c8eb092cf112b4022a77148a658806273c2.tar.gz
nixlib-1ef51c8eb092cf112b4022a77148a658806273c2.tar.bz2
nixlib-1ef51c8eb092cf112b4022a77148a658806273c2.tar.lz
nixlib-1ef51c8eb092cf112b4022a77148a658806273c2.tar.xz
nixlib-1ef51c8eb092cf112b4022a77148a658806273c2.tar.zst
nixlib-1ef51c8eb092cf112b4022a77148a658806273c2.zip
Merge pull request #12255 from svend/pinentry-mac
pinentry-mac: init at 0.9.4
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/security/pinentry-mac/default.nix26
1 files changed, 26 insertions, 0 deletions
diff --git a/pkgs/tools/security/pinentry-mac/default.nix b/pkgs/tools/security/pinentry-mac/default.nix
new file mode 100644
index 000000000000..faf8c613ea83
--- /dev/null
+++ b/pkgs/tools/security/pinentry-mac/default.nix
@@ -0,0 +1,26 @@
+{ fetchurl, stdenv }:
+
+stdenv.mkDerivation rec {
+  name = "pinentry-mac-0.9.4";
+
+  src = fetchurl {
+    url = "https://github.com/GPGTools/pinentry-mac/archive/v0.9.4.tar.gz";
+    sha256 = "037ebb010377d3a3879ae2a832cefc4513f5c397d7d887d7b86b4e5d9a628271";
+  };
+
+  postPatch = ''
+    substituteInPlace ./Makefile --replace "xcodebuild" "/usr/bin/xcodebuild"
+  '';
+
+  installPhase = ''
+    mkdir -p $out/Applications
+    mv build/Release/pinentry-mac.app $out/Applications
+  '';
+
+  meta = {
+    description = "Pinentry for GPG on Mac";
+    license = stdenv.lib.licenses.gpl2Plus;
+    homepage = "https://github.com/GPGTools/pinentry-mac";
+    platforms = stdenv.lib.platforms.darwin;
+  };
+}