summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authordbohdan <dbohdan@dbohdan.com>2018-05-18 17:10:00 +0300
committerdbohdan <dbohdan@dbohdan.com>2018-05-18 17:19:31 +0300
commit1d2eeec16c8d5b7fc3c4a365776a767dd080c599 (patch)
tree345e75ed7363fb2d863e01a92929aec1ebeb64ed /pkgs/tools
parente86be6919ad24ed4ecf9cc85cbee30d6939a7c29 (diff)
downloadnixlib-1d2eeec16c8d5b7fc3c4a365776a767dd080c599.tar
nixlib-1d2eeec16c8d5b7fc3c4a365776a767dd080c599.tar.gz
nixlib-1d2eeec16c8d5b7fc3c4a365776a767dd080c599.tar.bz2
nixlib-1d2eeec16c8d5b7fc3c4a365776a767dd080c599.tar.lz
nixlib-1d2eeec16c8d5b7fc3c4a365776a767dd080c599.tar.xz
nixlib-1d2eeec16c8d5b7fc3c4a365776a767dd080c599.tar.zst
nixlib-1d2eeec16c8d5b7fc3c4a365776a767dd080c599.zip
s2png: init at 0.7.2
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/graphics/s2png/default.nix24
1 files changed, 24 insertions, 0 deletions
diff --git a/pkgs/tools/graphics/s2png/default.nix b/pkgs/tools/graphics/s2png/default.nix
new file mode 100644
index 000000000000..fd538eec573d
--- /dev/null
+++ b/pkgs/tools/graphics/s2png/default.nix
@@ -0,0 +1,24 @@
+{ stdenv, fetchFromGitHub, diffutils, gd, pkgconfig }:
+
+stdenv.mkDerivation rec {
+  name = "s2png-${version}";
+  version = "0.7.2";
+
+  src = fetchFromGitHub {
+    owner = "dbohdan";
+    repo = "s2png";
+    rev = "v${version}";
+    sha256 = "0y3crfm0jqprgxamlly713cka2x1bp6z63p1lw9wh4wc37kpira6";
+  };
+
+  buildInputs = [ diffutils gd pkgconfig ];
+  installFlags = [ "prefix=" "DESTDIR=$(out)" ];
+
+  meta = {
+    homepage = https://github.com/dbohdan/s2png/;
+    description = "Store any data in PNG images";
+    license = stdenv.lib.licenses.gpl2;
+    maintainers = [ stdenv.lib.maintainers.dbohdan ];
+    platforms = stdenv.lib.platforms.unix;
+  };
+}