summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorWilliam A. Kennington III <william@wkennington.com>2015-08-01 18:05:40 -0700
committerWilliam A. Kennington III <william@wkennington.com>2015-08-01 18:05:51 -0700
commit1b20c87d1f9cb9e3a90fb3077d746a9f41dbb58e (patch)
tree39361250e2d29ead3f0bc0b656cdc0e85d5f1175 /pkgs/tools
parentdd41013dbace43cfe0ac6159c82cb193ef788355 (diff)
downloadnixlib-1b20c87d1f9cb9e3a90fb3077d746a9f41dbb58e.tar
nixlib-1b20c87d1f9cb9e3a90fb3077d746a9f41dbb58e.tar.gz
nixlib-1b20c87d1f9cb9e3a90fb3077d746a9f41dbb58e.tar.bz2
nixlib-1b20c87d1f9cb9e3a90fb3077d746a9f41dbb58e.tar.lz
nixlib-1b20c87d1f9cb9e3a90fb3077d746a9f41dbb58e.tar.xz
nixlib-1b20c87d1f9cb9e3a90fb3077d746a9f41dbb58e.tar.zst
nixlib-1b20c87d1f9cb9e3a90fb3077d746a9f41dbb58e.zip
ceph-git: 2015-07-29 -> 2015-07-31
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/filesystems/ceph/generic.nix7
-rw-r--r--pkgs/tools/filesystems/ceph/git.nix7
2 files changed, 7 insertions, 7 deletions
diff --git a/pkgs/tools/filesystems/ceph/generic.nix b/pkgs/tools/filesystems/ceph/generic.nix
index 51e304bec216..1130772ccd85 100644
--- a/pkgs/tools/filesystems/ceph/generic.nix
+++ b/pkgs/tools/filesystems/ceph/generic.nix
@@ -56,7 +56,7 @@ let
   optLibatomic_ops = shouldUsePkg libatomic_ops;
   optKinetic-cpp-client = shouldUsePkg kinetic-cpp-client;
   optRocksdb = shouldUsePkg rocksdb;
-  optLibs3 = shouldUsePkg libs3;
+  optLibs3 = if versionAtLeast version "10.0.0" then null else shouldUsePkg libs3;
 
   optJemalloc = shouldUsePkg jemalloc;
   optGperftools = shouldUsePkg gperftools;
@@ -195,8 +195,6 @@ stdenv.mkDerivation {
     (mkWith   hasKinetic                   "kinetic"             null)
     (mkWith   hasRocksdb                   "librocksdb"          null)
     (mkWith   false                        "librocksdb-static"   null)
-    (mkWith   (optLibs3 != null)           "system-libs3"        null)
-    (mkWith   true                         "rest-bench"          null)
   ] ++ optional stdenv.isLinux [
     (mkWith   (optLibaio != null)          "libaio"              null)
     (mkWith   (optLibxfs != null)          "libxfs"              null)
@@ -207,6 +205,9 @@ stdenv.mkDerivation {
   ] ++ optional (versionAtLeast version "9.0.2") [
     (mkWith   true                         "man-pages"           null)
     (mkWith   true                         "systemd-libexec-dir" "\${TMPDIR}")
+  ] ++ optional (versionOlder version "10.0.0") [
+    (mkWith   (optLibs3 != null)           "system-libs3"        null)
+    (mkWith   true                         "rest-bench"          null)
   ];
 
   preBuild = optionalString (versionAtLeast version "9.0.0") ''
diff --git a/pkgs/tools/filesystems/ceph/git.nix b/pkgs/tools/filesystems/ceph/git.nix
index 8534c2fdba38..913901a0f801 100644
--- a/pkgs/tools/filesystems/ceph/git.nix
+++ b/pkgs/tools/filesystems/ceph/git.nix
@@ -1,13 +1,12 @@
 { callPackage, fetchgit, ... } @ args:
 
 callPackage ./generic.nix (args // rec {
-  version = "2015-07-29";
+  version = "2015-07-31";
 
   src = fetchgit {
     url = "git://github.com/ceph/ceph.git";
-    rev = "338ead0f498238fd1b5b7f18d86ad407de6f347b";
-    leaveDotGit = true;
-    sha256 = "0ip62l4qkcmszbczwdnqhn93glnpgy0fhymf627x0vf49dgv3a6i";
+    rev = "ef86e29259d0e863e62115926bf67287dc9a7e41";
+    sha256 = "14h387ngx3fmdm0b0sgl0l743j3d22gnp3lv68ah59yc4crfgdcx";
   };
 
   patches = [ ./fix-pythonpath.patch ];