summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorArseniy Seroka <jagajaga@users.noreply.github.com>2015-12-29 14:59:20 +0300
committerArseniy Seroka <jagajaga@users.noreply.github.com>2015-12-29 14:59:20 +0300
commit19b6034135f3efe108ec56a3cbd0252bc5743537 (patch)
treea58e8ca1ac6627f2d3b9dfa0c7f8b22ceaede5b1 /pkgs/tools
parent729211de7a441eedc3b7aeb3fce84e1dfd57ff1b (diff)
parent5120601c28977ac8681df1192b2008e681e21a05 (diff)
downloadnixlib-19b6034135f3efe108ec56a3cbd0252bc5743537.tar
nixlib-19b6034135f3efe108ec56a3cbd0252bc5743537.tar.gz
nixlib-19b6034135f3efe108ec56a3cbd0252bc5743537.tar.bz2
nixlib-19b6034135f3efe108ec56a3cbd0252bc5743537.tar.lz
nixlib-19b6034135f3efe108ec56a3cbd0252bc5743537.tar.xz
nixlib-19b6034135f3efe108ec56a3cbd0252bc5743537.tar.zst
nixlib-19b6034135f3efe108ec56a3cbd0252bc5743537.zip
Merge pull request #11995 from dezgeg/pr-yledl
yle-dl: init at 2.9.1
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/misc/yle-dl/default.nix36
1 files changed, 36 insertions, 0 deletions
diff --git a/pkgs/tools/misc/yle-dl/default.nix b/pkgs/tools/misc/yle-dl/default.nix
new file mode 100644
index 000000000000..c6efac3ffe60
--- /dev/null
+++ b/pkgs/tools/misc/yle-dl/default.nix
@@ -0,0 +1,36 @@
+{ stdenv, fetchFromGitHub, rtmpdump, php, pythonPackages }:
+
+stdenv.mkDerivation rec {
+  name = "yle-dl-${version}";
+  version = "2.9.1";
+
+  src = fetchFromGitHub {
+    owner = "aajanki";
+    repo = "yle-dl";
+    rev = version;
+    sha256 = "1irpcp9iw2cw85sj1kzndmrw8350p9q7cfghjx2xkh2czk9k7whq";
+  };
+
+  patchPhase = ''
+    substituteInPlace yle-dl --replace '/usr/local/share/' "$out/share/"
+
+    # HACK: work around https://github.com/NixOS/nixpkgs/issues/9593
+    substituteInPlace yle-dl --replace '/usr/bin/env python2' '/usr/bin/env python'
+  '';
+
+  buildInputs = [ pythonPackages.wrapPython ];
+  pythonPath = [ rtmpdump php ] ++ (with pythonPackages; [ pycrypto ]);
+
+  installPhase = ''
+    make install prefix=$out
+    wrapPythonPrograms
+  '';
+
+  meta = with stdenv.lib; {
+    description = "Downloads videos from Yle (Finnish Broadcasting Company) servers";
+    homepage = https://aajanki.github.io/yle-dl/;
+    license = licenses.gpl3;
+    maintainers = [ maintainers.dezgeg ];
+    platforms = platforms.linux;
+  };
+}