summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorThomas Tuegel <ttuegel@gmail.com>2016-07-28 19:14:37 -0500
committerThomas Tuegel <ttuegel@gmail.com>2016-07-28 19:14:37 -0500
commit173d668456fabfe2383c6181e4f84ca8f56d032e (patch)
tree034dd5187db59a45977f37490615905906ebce3a /pkgs/tools
parent83f783c00fe7c71c48eef93afdf9a3fd3cb9319e (diff)
parent1db8808b2df405c6dec4ed8942b332635678479c (diff)
downloadnixlib-173d668456fabfe2383c6181e4f84ca8f56d032e.tar
nixlib-173d668456fabfe2383c6181e4f84ca8f56d032e.tar.gz
nixlib-173d668456fabfe2383c6181e4f84ca8f56d032e.tar.bz2
nixlib-173d668456fabfe2383c6181e4f84ca8f56d032e.tar.lz
nixlib-173d668456fabfe2383c6181e4f84ca8f56d032e.tar.xz
nixlib-173d668456fabfe2383c6181e4f84ca8f56d032e.tar.zst
nixlib-173d668456fabfe2383c6181e4f84ca8f56d032e.zip
Merge branch 'kde-frameworks-qt55'
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/inputmethods/fcitx/fcitx-ecm.patch25
-rw-r--r--pkgs/tools/inputmethods/fcitx/fcitx-qt5.nix16
2 files changed, 3 insertions, 38 deletions
diff --git a/pkgs/tools/inputmethods/fcitx/fcitx-ecm.patch b/pkgs/tools/inputmethods/fcitx/fcitx-ecm.patch
deleted file mode 100644
index 8a886f2bc78e..000000000000
--- a/pkgs/tools/inputmethods/fcitx/fcitx-ecm.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index fd54ad8..ebb33d0 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -5,8 +5,7 @@ project(fcitx)
- set(version 4.2.9)
- 
- 
--find_package(ECM 0.0.11 REQUIRED NO_MODULE)
--set(CMAKE_MODULE_PATH "${ECM_MODULE_PATH}" "${CMAKE_CURRENT_SOURCE_DIR}/cmake" ${CMAKE_MODULE_PATH})
-+set(CMAKE_MODULE_PATH "${CMAKE_CURRENT_SOURCE_DIR}/cmake" ${CMAKE_MODULE_PATH})
- set(CMAKE_AUTOMOC_RELAXED_MODE TRUE)
- 
- set_property(GLOBAL PROPERTY "__FCITX_INTERNAL_BUILD" On)
---- a/cmake/FindXKBCommon.cmake
-+++ b/cmake/FindXKBCommon.cmake
-@@ -1,5 +1,5 @@
- 
--include(ECMFindModuleHelpersStub)
-+include(ECMFindModuleHelpers)
- 
- ecm_find_package_version_check(XKBCommon)
- 
--- 
-2.8.0
diff --git a/pkgs/tools/inputmethods/fcitx/fcitx-qt5.nix b/pkgs/tools/inputmethods/fcitx/fcitx-qt5.nix
index fc9dd1e6a253..3f421e327d71 100644
--- a/pkgs/tools/inputmethods/fcitx/fcitx-qt5.nix
+++ b/pkgs/tools/inputmethods/fcitx/fcitx-qt5.nix
@@ -1,4 +1,4 @@
-{ stdenv, lib, fetchurl, cmake, fcitx, pkgconfig, qtbase, kde5 }:
+{ stdenv, lib, fetchurl, cmake, fcitx, pkgconfig, qtbase, extra-cmake-modules }:
 
 stdenv.mkDerivation rec {
   name = "fcitx-qt5-${version}";
@@ -9,19 +9,9 @@ stdenv.mkDerivation rec {
     sha256 = "1pj1b04n8r4kl7jh1qdv0xshgzb3zrmizfa3g5h3yk589h191vwc";
   };
 
-  # The following is to not have a dependency on kde5 so the plugin can be part of qt5LibsFun
-  postUnpack = ''
-    ${lib.concatMapStrings (f: ''
-      ln -s ${kde5.extra-cmake-modules}/share/ECM/modules/${f} $sourceRoot/cmake/
-    '')
-    [ "ECMFindModuleHelpers.cmake" "ECMGenerateHeaders.cmake"
-      "ECMPackageConfigHelpers.cmake" "ECMQueryQmake.cmake"
-      "ECMSetupVersion.cmake" "ECMVersionHeader.h.in" ]}
-  '';
-
-  patches = [ ./fcitx-qt5-ecm.patch ];
+  nativeBuildInputs = [ cmake extra-cmake-modules pkgconfig ];
 
-  buildInputs = [ cmake fcitx pkgconfig qtbase ];
+  buildInputs = [ fcitx qtbase ];
 
   preInstall = ''
     substituteInPlace platforminputcontext/cmake_install.cmake \