summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorMatthew Justin Bauer <mjbauer95@gmail.com>2018-04-08 21:49:48 -0500
committerGitHub <noreply@github.com>2018-04-08 21:49:48 -0500
commit1381606b8ecfdce3c4491b6df70814e07c58ed82 (patch)
treeb16d91cb8ce8b93162addbdf43cdef576f2d5157 /pkgs/tools
parent842278d6752bfdaefdc204bfdeddc162db7cdbbc (diff)
parentb3aa9ecdf8963e38d2e0a7ea0cb90b44da7de9a8 (diff)
downloadnixlib-1381606b8ecfdce3c4491b6df70814e07c58ed82.tar
nixlib-1381606b8ecfdce3c4491b6df70814e07c58ed82.tar.gz
nixlib-1381606b8ecfdce3c4491b6df70814e07c58ed82.tar.bz2
nixlib-1381606b8ecfdce3c4491b6df70814e07c58ed82.tar.lz
nixlib-1381606b8ecfdce3c4491b6df70814e07c58ed82.tar.xz
nixlib-1381606b8ecfdce3c4491b6df70814e07c58ed82.tar.zst
nixlib-1381606b8ecfdce3c4491b6df70814e07c58ed82.zip
Merge pull request #38533 from nyanloutre/duplicati-package
duplicati: init at 2.0.3.3
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/backup/duplicati/default.nix37
1 files changed, 37 insertions, 0 deletions
diff --git a/pkgs/tools/backup/duplicati/default.nix b/pkgs/tools/backup/duplicati/default.nix
new file mode 100644
index 000000000000..d36ef7ea64fb
--- /dev/null
+++ b/pkgs/tools/backup/duplicati/default.nix
@@ -0,0 +1,37 @@
+{ stdenv, fetchzip, mono, sqlite, makeWrapper }:
+
+stdenv.mkDerivation rec {
+  name = "duplicati-${version}";
+  version = "2.0.3.3";
+  channel = "beta";
+  build_date = "2018-04-02";
+
+  src = fetchzip {
+    url = "https://github.com/duplicati/duplicati/releases/download/v${version}-${version}_${channel}_${build_date}/duplicati-${version}_${channel}_${build_date}.zip";
+    sha256 = "0hwdpsgrvm3gq648mg9g0z0rk49g71dd8r5i1a8w83pwdqv0hn9c";
+    stripRoot = false;
+  };
+
+  buildInputs = [ makeWrapper ];
+
+  installPhase = ''
+    mkdir -p $out/{bin,share/${name}}
+    cp -r * $out/share/${name}
+    makeWrapper "${mono}/bin/mono" $out/bin/duplicati-cli \
+      --add-flags "$out/share/${name}/Duplicati.CommandLine.exe" \
+      --prefix LD_LIBRARY_PATH : ${stdenv.lib.makeLibraryPath [
+          sqlite ]}
+    makeWrapper "${mono}/bin/mono" $out/bin/duplicati-server \
+      --add-flags "$out/share/${name}/Duplicati.Server.exe" \
+      --prefix LD_LIBRARY_PATH : ${stdenv.lib.makeLibraryPath [
+          sqlite ]}
+  '';
+
+  meta = with stdenv.lib; {
+    description = "A free backup client that securely stores encrypted, incremental, compressed backups on cloud storage services and remote file servers";
+    homepage = https://www.duplicati.com/;
+    license = licenses.lgpl21;
+    maintainers = with maintainers; [ nyanloutre ];
+    platforms = platforms.all;
+  };
+}