summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorKirill Boltaev <aske@fmap.me>2016-09-13 20:42:55 +0300
committerKirill Boltaev <aske@fmap.me>2016-09-13 21:09:24 +0300
commit0f37287df5c4ba0343c292ddfe827224efa87daf (patch)
treece3a7a0659c5c478cb75c96c93051b83532a8d9b /pkgs/tools
parent4b55b0358ad7c636b581bb8b665540f013ef68af (diff)
downloadnixlib-0f37287df5c4ba0343c292ddfe827224efa87daf.tar
nixlib-0f37287df5c4ba0343c292ddfe827224efa87daf.tar.gz
nixlib-0f37287df5c4ba0343c292ddfe827224efa87daf.tar.bz2
nixlib-0f37287df5c4ba0343c292ddfe827224efa87daf.tar.lz
nixlib-0f37287df5c4ba0343c292ddfe827224efa87daf.tar.xz
nixlib-0f37287df5c4ba0343c292ddfe827224efa87daf.tar.zst
nixlib-0f37287df5c4ba0343c292ddfe827224efa87daf.zip
treewide: explicitly specify gtk version
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/networking/mtr/default.nix6
-rw-r--r--pkgs/tools/security/nmap/default.nix4
-rw-r--r--pkgs/tools/system/lshw/default.nix4
3 files changed, 7 insertions, 7 deletions
diff --git a/pkgs/tools/networking/mtr/default.nix b/pkgs/tools/networking/mtr/default.nix
index af5155695f48..c96e5cac367c 100644
--- a/pkgs/tools/networking/mtr/default.nix
+++ b/pkgs/tools/networking/mtr/default.nix
@@ -1,7 +1,7 @@
 {stdenv, fetchurl, ncurses, autoconf
-, withGtk ? false, gtk ? null}:
+, withGtk ? false, gtk2 ? null}:
 
-assert withGtk -> gtk != null;
+assert withGtk -> gtk2 != null;
 
 with stdenv.lib;
 stdenv.mkDerivation rec {
@@ -16,7 +16,7 @@ stdenv.mkDerivation rec {
 
   configureFlags = optionalString (!withGtk) "--without-gtk";
 
-  buildInputs = [ autoconf ncurses ] ++ optional withGtk gtk;
+  buildInputs = [ autoconf ncurses ] ++ optional withGtk gtk2;
 
   meta = {
     homepage = http://www.bitwizard.nl/mtr/;
diff --git a/pkgs/tools/security/nmap/default.nix b/pkgs/tools/security/nmap/default.nix
index e1a46cf2b82a..3bc5d4158346 100644
--- a/pkgs/tools/security/nmap/default.nix
+++ b/pkgs/tools/security/nmap/default.nix
@@ -1,7 +1,7 @@
 { stdenv, fetchurl, libpcap, pkgconfig, openssl
 , graphicalSupport ? false
 , libX11 ? null
-, gtk ? null
+, gtk2 ? null
 , pythonPackages
 , makeWrapper ? null
 }:
@@ -31,7 +31,7 @@ in stdenv.mkDerivation rec {
 
   buildInputs = [ libpcap pkgconfig openssl makeWrapper python ]
     ++ optionals graphicalSupport [
-      libX11 gtk pygtk pysqlite pygobject2 pycairo
+      libX11 gtk2 pygtk pysqlite pygobject2 pycairo
     ];
 
   meta = {
diff --git a/pkgs/tools/system/lshw/default.nix b/pkgs/tools/system/lshw/default.nix
index 02b331a36deb..75ad15b7311d 100644
--- a/pkgs/tools/system/lshw/default.nix
+++ b/pkgs/tools/system/lshw/default.nix
@@ -1,5 +1,5 @@
 { stdenv, fetchurl
-, withGUI? false, gtk? null, pkgconfig? null, sqlite? null  # compile GUI
+, withGUI ? false, gtk2 ? null, pkgconfig? null, sqlite ? null  # compile GUI
  }:
 stdenv.mkDerivation rec {
 
@@ -11,7 +11,7 @@ stdenv.mkDerivation rec {
     sha256 = "1728b96gyjmrp31knzips9azn6wkfdp5k5dnbil7h7hgz99w177b";
   };
 
-  buildInputs = [] ++ stdenv.lib.optional withGUI [ gtk pkgconfig sqlite ];
+  buildInputs = [] ++ stdenv.lib.optional withGUI [ gtk2 pkgconfig sqlite ];
 
   postBuild = if withGUI then "make gui" else "";