summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorJörg Thalheim <Mic92@users.noreply.github.com>2018-10-28 23:12:43 +0000
committerGitHub <noreply@github.com>2018-10-28 23:12:43 +0000
commit0e72714d5df9dc50a8191cb0f2a10b3db7ec9a79 (patch)
treea77a3b055613e662194493b75c400db55f489788 /pkgs/tools
parentc33e3a3899f5f3dc633b98cd815a8f06ffe56ef8 (diff)
parentf03929f6496ae3cacc050093040a279f894865b4 (diff)
downloadnixlib-0e72714d5df9dc50a8191cb0f2a10b3db7ec9a79.tar
nixlib-0e72714d5df9dc50a8191cb0f2a10b3db7ec9a79.tar.gz
nixlib-0e72714d5df9dc50a8191cb0f2a10b3db7ec9a79.tar.bz2
nixlib-0e72714d5df9dc50a8191cb0f2a10b3db7ec9a79.tar.lz
nixlib-0e72714d5df9dc50a8191cb0f2a10b3db7ec9a79.tar.xz
nixlib-0e72714d5df9dc50a8191cb0f2a10b3db7ec9a79.tar.zst
nixlib-0e72714d5df9dc50a8191cb0f2a10b3db7ec9a79.zip
Merge pull request #49358 from Mic92/nixdoc
nixdoc: init at 1.0.1
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/nix/nixdoc/default.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/pkgs/tools/nix/nixdoc/default.nix b/pkgs/tools/nix/nixdoc/default.nix
new file mode 100644
index 000000000000..d84a85071df7
--- /dev/null
+++ b/pkgs/tools/nix/nixdoc/default.nix
@@ -0,0 +1,25 @@
+{ stdenv, callPackage, fetchFromGitHub, rustPlatform, darwin }:
+
+rustPlatform.buildRustPackage rec {
+  name    = "nixdoc-${version}";
+  version = "1.0.1";
+
+  src = fetchFromGitHub {
+    owner = "tazjin";
+    repo  = "nixdoc";
+    rev = "v${version}";
+    sha256 = "14d4dq06jdqazxvv7fq5872zy0capxyb0fdkp8qg06gxl1iw201s";
+  };
+
+  buildInputs =  stdenv.lib.optional stdenv.isDarwin [ darwin.Security ];
+
+  cargoSha256 = "1bfn1x1jhpyidai4cjwip5r1ibkqp26ivmqq3vjm71l00m6avb94";
+
+  meta = with stdenv.lib; {
+    description = "Generate documentation for Nix functions";
+    homepage    = https://github.com/tazjin/nixdoc;
+    license     = [ licenses.gpl3 ];
+    maintainers = [ maintainers.tazjin ];
+    platforms   = platforms.unix;
+  };
+}