summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorThomas Strobel <ts468@cam.ac.uk>2014-10-14 01:53:35 +0200
committerThomas Strobel <ts468@cam.ac.uk>2014-10-14 09:00:31 +0200
commit0dd66a50de7ef3c5f60234c4c865afa533892e9b (patch)
tree2b1c4c04364cd2636ea77746858b240d0f479ebb /pkgs/tools
parente17781f8b1a10e40f4ec110e01610c8afaae4c38 (diff)
downloadnixlib-0dd66a50de7ef3c5f60234c4c865afa533892e9b.tar
nixlib-0dd66a50de7ef3c5f60234c4c865afa533892e9b.tar.gz
nixlib-0dd66a50de7ef3c5f60234c4c865afa533892e9b.tar.bz2
nixlib-0dd66a50de7ef3c5f60234c4c865afa533892e9b.tar.lz
nixlib-0dd66a50de7ef3c5f60234c4c865afa533892e9b.tar.xz
nixlib-0dd66a50de7ef3c5f60234c4c865afa533892e9b.tar.zst
nixlib-0dd66a50de7ef3c5f60234c4c865afa533892e9b.zip
Update: trousers 0.3.11 -> 0.3.13
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/security/trousers/default.nix18
-rw-r--r--pkgs/tools/security/trousers/disable-install-rule.patch27
-rw-r--r--pkgs/tools/security/trousers/double-installed-man-page.patch32
3 files changed, 7 insertions, 70 deletions
diff --git a/pkgs/tools/security/trousers/default.nix b/pkgs/tools/security/trousers/default.nix
index fe797291f9ea..70f11c39d6fc 100644
--- a/pkgs/tools/security/trousers/default.nix
+++ b/pkgs/tools/security/trousers/default.nix
@@ -1,23 +1,19 @@
 { stdenv, fetchurl, openssl }:
 
-let
-  ver_maj = "0.3.11";
-  ver_min = "2";
-in
 stdenv.mkDerivation rec {
-  name = "trousers-${ver_maj}.${ver_min}";
+  name = "trousers-${version}";
+  version = "0.3.13";
 
   src = fetchurl {
-    url = "mirror://sourceforge/trousers/trousers/${ver_maj}/${name}.tar.gz";
-    sha256 = "1m9qi4452jr5yy4y9zyfi5ndwam5krq7ny8z2q3f91v1hcjgk5la";
+    url = "mirror://sourceforge/trousers/trousers/${version}/${name}.tar.gz";
+    sha256 = "1lvnla1c1ig2w3xvvrqg2w9qm7a1ygzy1j2gg8j7p8c87i58x45v";
   };
 
   buildInputs = [ openssl ];
 
-  patches = [ # ./double-installed-man-page.patch
-              ./disable-install-rule.patch
-              ./allow-non-tss-config-file-owner.patch
-            ];
+  patches = [ ./allow-non-tss-config-file-owner.patch ];
+
+  configureFlags = [ "--disable-usercheck" ];
 
   NIX_CFLAGS_COMPILE = "-DALLOW_NON_TSS_CONFIG_FILE";
   NIX_LDFLAGS = "-lgcc_s";
diff --git a/pkgs/tools/security/trousers/disable-install-rule.patch b/pkgs/tools/security/trousers/disable-install-rule.patch
deleted file mode 100644
index 698beac9ffde..000000000000
--- a/pkgs/tools/security/trousers/disable-install-rule.patch
+++ /dev/null
@@ -1,27 +0,0 @@
---- trousers-0.3.11/dist/Makefile.in	2013-08-14 06:49:37.597558787 +0200
-+++ trousers-0.3.11/dist/Makefile.in	2013-08-14 06:50:07.134510774 +0200
-@@ -363,16 +363,16 @@
- 	uninstall uninstall-am uninstall-hook
- 
- install: install-exec-hook
--	if test ! -e ${DESTDIR}/@sysconfdir@/tcsd.conf; then mkdir -p ${DESTDIR}/@sysconfdir@ && cp tcsd.conf ${DESTDIR}/@sysconfdir@; fi
--	/bin/chown tss:tss ${DESTDIR}/@sysconfdir@/tcsd.conf || true
--	/bin/chmod 0600 ${DESTDIR}/@sysconfdir@/tcsd.conf
-+#	echo if test ! -e ${DESTDIR}/@sysconfdir@/tcsd.conf; then mkdir -p ${DESTDIR}/@sysconfdir@ && cp tcsd.conf ${DESTDIR}/@sysconfdir@; fi
-+	echo /bin/chown tss:tss ${DESTDIR}/@sysconfdir@/tcsd.conf || true
-+	echo /bin/chmod 0600 ${DESTDIR}/@sysconfdir@/tcsd.conf
- 
- install-exec-hook:
--	/usr/sbin/groupadd tss || true
--	/usr/sbin/useradd -r tss -g tss || true
--	/bin/sh -c 'if [ ! -e ${DESTDIR}/@localstatedir@/lib/tpm ];then mkdir -p ${DESTDIR}/@localstatedir@/lib/tpm; fi'
--	/bin/chown tss:tss ${DESTDIR}/@localstatedir@/lib/tpm || true
--	/bin/chmod 0700 ${DESTDIR}/@localstatedir@/lib/tpm
-+	echo /usr/sbin/groupadd tss || true
-+	echo /usr/sbin/useradd -r tss -g tss || true
-+	echo /bin/sh -c 'if [ ! -e ${DESTDIR}/@localstatedir@/lib/tpm ];then mkdir -p ${DESTDIR}/@localstatedir@/lib/tpm; fi'
-+	echo /bin/chown tss:tss ${DESTDIR}/@localstatedir@/lib/tpm || true
-+	echo /bin/chmod 0700 ${DESTDIR}/@localstatedir@/lib/tpm
- 
- uninstall-hook:
- 	/usr/sbin/userdel tss || true
diff --git a/pkgs/tools/security/trousers/double-installed-man-page.patch b/pkgs/tools/security/trousers/double-installed-man-page.patch
deleted file mode 100644
index 6b40716120ea..000000000000
--- a/pkgs/tools/security/trousers/double-installed-man-page.patch
+++ /dev/null
@@ -1,32 +0,0 @@
---- trousers-0.3.11/man/man3/Makefile.am	2013-08-14 04:57:47.018494495 +0200
-+++ trousers-0.3.11/man/man3/Makefile.am	2013-08-14 04:58:10.353453471 +0200
-@@ -75,7 +75,6 @@
- 	    Tspi_TPM_TakeOwnership.3 \
- 	    Tspi_TPM_GetAuditDigest.3 \
- 	    Tspi_TPM_OwnerGetSRKPubKey.3 \
--	    Tspi_TPM_Quote.3 \
- 	    Tspi_TPM_CMKSetRestrictions.3
- if TSS_BUILD_DAA
- man3_MANS += Tspi_DAA_IssueCredential.3 \
---- trousers-0.3.11/man/man3/Makefile.in	2013-08-14 05:06:25.029490899 +0200
-+++ trousers-0.3.11/man/man3/Makefile.in	2013-08-14 05:06:43.153457942 +0200
-@@ -243,7 +243,7 @@
- 	Tspi_TPM_PcrExtend.3 Tspi_TPM_Quote.3 Tspi_TPM_SelfTestFull.3 \
- 	Tspi_TPM_SetStatus.3 Tspi_TPM_StirRandom.3 \
- 	Tspi_TPM_TakeOwnership.3 Tspi_TPM_GetAuditDigest.3 \
--	Tspi_TPM_OwnerGetSRKPubKey.3 Tspi_TPM_Quote.3 \
-+	Tspi_TPM_OwnerGetSRKPubKey.3 \
- 	Tspi_TPM_CMKSetRestrictions.3 $(am__append_1)
- EXTRA_DIST = $(man3_MANS)
- all: all-am
---- trousers-0.3.11/man/man3/Makefile	2013-08-14 05:07:05.686414845 +0200
-+++ trousers-0.3.11/man/man3/Makefile	2013-08-14 05:07:23.233381327 +0200
-@@ -243,7 +243,7 @@
- 	Tspi_TPM_PcrExtend.3 Tspi_TPM_Quote.3 Tspi_TPM_SelfTestFull.3 \
- 	Tspi_TPM_SetStatus.3 Tspi_TPM_StirRandom.3 \
- 	Tspi_TPM_TakeOwnership.3 Tspi_TPM_GetAuditDigest.3 \
--	Tspi_TPM_OwnerGetSRKPubKey.3 Tspi_TPM_Quote.3 \
-+	Tspi_TPM_OwnerGetSRKPubKey.3 \
- 	Tspi_TPM_CMKSetRestrictions.3 $(am__append_1)
- EXTRA_DIST = $(man3_MANS)
- all: all-am