summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorShea Levy <shea@shealevy.com>2014-04-06 07:16:46 -0400
committerShea Levy <shea@shealevy.com>2014-04-06 07:16:46 -0400
commit0bab5319cca1b893603fb02e81434b50aacd1f08 (patch)
tree7b993d193677dde582420d348820085e42e952cd /pkgs/tools
parentbf129a2c238e5ffe99e7778851042c16ba467496 (diff)
parent1653c118bd079d0ba19fc85c8abe94e35739db53 (diff)
downloadnixlib-0bab5319cca1b893603fb02e81434b50aacd1f08.tar
nixlib-0bab5319cca1b893603fb02e81434b50aacd1f08.tar.gz
nixlib-0bab5319cca1b893603fb02e81434b50aacd1f08.tar.bz2
nixlib-0bab5319cca1b893603fb02e81434b50aacd1f08.tar.lz
nixlib-0bab5319cca1b893603fb02e81434b50aacd1f08.tar.xz
nixlib-0bab5319cca1b893603fb02e81434b50aacd1f08.tar.zst
nixlib-0bab5319cca1b893603fb02e81434b50aacd1f08.zip
Merge branch 'pastebinit' of git://github.com/lethalman/nixpkgs
pastebinit: new package
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/misc/pastebinit/default.nix33
1 files changed, 33 insertions, 0 deletions
diff --git a/pkgs/tools/misc/pastebinit/default.nix b/pkgs/tools/misc/pastebinit/default.nix
new file mode 100644
index 000000000000..cf41de29c500
--- /dev/null
+++ b/pkgs/tools/misc/pastebinit/default.nix
@@ -0,0 +1,33 @@
+{ stdenv, fetchurl, python3Packages }:
+
+python3Packages.buildPythonPackage rec {
+  version = "1.4.1";
+  name = "pastebinit-${version}";
+
+  src = fetchurl {
+    url = "https://launchpad.net/pastebinit/trunk/${version}/+download/${name}.tar.bz2";
+    md5 = "b771872a9483cf92be90a3e4420fd3c9";
+  };
+
+  configurePhase = "export DETERMINISTIC_BUILD=1";
+
+  buildPhase = "";
+
+  installPhase = ''
+    mkdir -p $out/bin
+    mkdir -p $out/etc
+    cp -a pastebinit $out/bin
+    cp -a pastebin.d $out/etc
+    substituteInPlace $out/bin/pastebinit --replace "'/etc/pastebin.d" "'$out/etc/pastebin.d"
+  '';
+
+  doCheck = false;
+
+  meta = with stdenv.lib; {
+    homepage = https://launchpad.net/pastebinit;
+    description = "A software that lets you send anything you want directly to a pastebin from the command line";
+    maintainers = with maintainers; [ lethalman ];
+    license = licenses.gpl2;
+    platforms = platforms.linux;
+  };
+}