summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorMatthew Bauer <mjbauer95@gmail.com>2018-10-29 10:15:19 -0500
committerMatthew Bauer <mjbauer95@gmail.com>2018-10-29 13:45:40 -0500
commit075e4883e0abea400aecb886e6244a6c2acf7bd8 (patch)
tree4b7a99900f1d7fe78b45189fee9475210a20e8d0 /pkgs/tools
parente6c0b6ff6fa70d480c37cfc118ee7a52dfaa699d (diff)
downloadnixlib-075e4883e0abea400aecb886e6244a6c2acf7bd8.tar
nixlib-075e4883e0abea400aecb886e6244a6c2acf7bd8.tar.gz
nixlib-075e4883e0abea400aecb886e6244a6c2acf7bd8.tar.bz2
nixlib-075e4883e0abea400aecb886e6244a6c2acf7bd8.tar.lz
nixlib-075e4883e0abea400aecb886e6244a6c2acf7bd8.tar.xz
nixlib-075e4883e0abea400aecb886e6244a6c2acf7bd8.tar.zst
nixlib-075e4883e0abea400aecb886e6244a6c2acf7bd8.zip
ibus: fix cross compilation
gtk-doc is a native input so we need to use buildPackages here.
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/inputmethods/ibus/default.nix5
1 files changed, 3 insertions, 2 deletions
diff --git a/pkgs/tools/inputmethods/ibus/default.nix b/pkgs/tools/inputmethods/ibus/default.nix
index 540779477e35..3b6f3c989a33 100644
--- a/pkgs/tools/inputmethods/ibus/default.nix
+++ b/pkgs/tools/inputmethods/ibus/default.nix
@@ -1,7 +1,8 @@
 { stdenv, fetchurl, fetchFromGitHub, autoreconfHook, gconf, intltool, makeWrapper, pkgconfig
 , vala, wrapGAppsHook, dbus, dconf ? null, glib, gdk_pixbuf, gobjectIntrospection, gtk2
 , gtk3, gtk-doc, isocodes, python3, json-glib, libnotify ? null, enablePythonLibrary ? true
-, enableUI ? true, withWayland ? false, libxkbcommon ? null, wayland ? null }:
+, enableUI ? true, withWayland ? false, libxkbcommon ? null, wayland ? null
+, buildPackages }:
 
 assert withWayland -> wayland != null && libxkbcommon != null;
 
@@ -76,7 +77,7 @@ stdenv.mkDerivation rec {
     substituteInPlace data/dconf/Makefile.am --replace "dconf update" true
     substituteInPlace configure.ac --replace '$python2dir/ibus' $out/${python3.sitePackages}/ibus
     echo \#!${stdenv.shell} > data/dconf/make-dconf-override-db.sh
-    cp ${gtk-doc}/share/gtk-doc/data/gtk-doc.make .
+    cp ${buildPackages.gtk-doc}/share/gtk-doc/data/gtk-doc.make .
   '';
 
   preAutoreconf = "touch ChangeLog";