summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorJoachim Schiele <js@lastlog.de>2014-09-18 18:08:38 +0200
committerJoachim Schiele <js@lastlog.de>2014-09-18 18:08:38 +0200
commit03b411d96814626df9b699335f356d43fdf4a9c5 (patch)
tree6abf2993893620da2d2d3116335e5380e68ac0e9 /pkgs/tools
parent2a3bae70b4f14524fd1e210220a35db37e71025d (diff)
parentdc86f52740690888d87f5fa65ae566b6e0746bbf (diff)
downloadnixlib-03b411d96814626df9b699335f356d43fdf4a9c5.tar
nixlib-03b411d96814626df9b699335f356d43fdf4a9c5.tar.gz
nixlib-03b411d96814626df9b699335f356d43fdf4a9c5.tar.bz2
nixlib-03b411d96814626df9b699335f356d43fdf4a9c5.tar.lz
nixlib-03b411d96814626df9b699335f356d43fdf4a9c5.tar.xz
nixlib-03b411d96814626df9b699335f356d43fdf4a9c5.tar.zst
nixlib-03b411d96814626df9b699335f356d43fdf4a9c5.zip
Merge pull request #4150 from qknight/dfc
dfc-3.0.4: a colored df -h replacement
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/system/dfc/default.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/pkgs/tools/system/dfc/default.nix b/pkgs/tools/system/dfc/default.nix
new file mode 100644
index 000000000000..84150b468378
--- /dev/null
+++ b/pkgs/tools/system/dfc/default.nix
@@ -0,0 +1,21 @@
+{stdenv, fetchurl, cmake, gettext}:
+
+stdenv.mkDerivation rec {
+  name = "dfc-3.0.4";
+
+  src = fetchurl {
+    url = "http://projects.gw-computing.net/attachments/download/79/dfc-3.0.4.tar.gz";
+    sha256 = "0bdc2edb92c7f740a0b7d3fa75eb134adf197ba711bfa589ab51c691fabd617e";
+  };
+
+  buildInputs = [ cmake gettext ];
+
+  meta = {
+    homepage = "http://projects.gw-computing.net/projects/dfc";
+    description = "displays file system space usage using graphs and colors";
+    license="free";
+    maintainers = with stdenv.lib.maintainers; [qknight];
+    platforms = with stdenv.lib.platforms; all;
+  };
+}
+