summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorMatthew Justin Bauer <mjbauer95@gmail.com>2018-06-01 23:14:35 -0400
committerGitHub <noreply@github.com>2018-06-01 23:14:35 -0400
commit0135f04d778df96d4b6427ddc441f2eab565057b (patch)
tree459e653fd931180398004fa3e500f0842bf4efc2 /pkgs/tools
parentcf152c2791c3a525736bcd540422d9b99a8f2a38 (diff)
parenta3e239ac6233dc895edaf90d8d4ba6728d4d4a41 (diff)
downloadnixlib-0135f04d778df96d4b6427ddc441f2eab565057b.tar
nixlib-0135f04d778df96d4b6427ddc441f2eab565057b.tar.gz
nixlib-0135f04d778df96d4b6427ddc441f2eab565057b.tar.bz2
nixlib-0135f04d778df96d4b6427ddc441f2eab565057b.tar.lz
nixlib-0135f04d778df96d4b6427ddc441f2eab565057b.tar.xz
nixlib-0135f04d778df96d4b6427ddc441f2eab565057b.tar.zst
nixlib-0135f04d778df96d4b6427ddc441f2eab565057b.zip
Merge pull request #40242 from gnidorah/gvt
linux: enable support for iGVT-g VGPU
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/networking/phodav/default.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/pkgs/tools/networking/phodav/default.nix b/pkgs/tools/networking/phodav/default.nix
new file mode 100644
index 000000000000..e585af81991e
--- /dev/null
+++ b/pkgs/tools/networking/phodav/default.nix
@@ -0,0 +1,25 @@
+{ stdenv, fetchurl
+, intltool, pkgconfig, glib, libsoup }:
+
+let
+  version = "2.2";
+in stdenv.mkDerivation rec {
+  name = "phodav-${version}";
+
+  src = fetchurl {
+    url = "http://ftp.gnome.org/pub/GNOME/sources/phodav/${version}/${name}.tar.xz";
+    sha256 = "1hap0lncbcmivnflh0fbx7y58ry78p9wgj7z03r64ic0kvf0a0q8";
+  };
+
+  buildInputs = [ intltool glib libsoup ];
+
+  nativeBuildInputs = [ pkgconfig ];
+
+  meta = with stdenv.lib; {
+    description = "WebDav server implementation and library using libsoup";
+    homepage = https://wiki.gnome.org/phodav;
+    license = licenses.lgpl21;
+    maintainers = with maintainers; [ gnidorah ];
+    platforms = platforms.linux;
+  };
+}