summary refs log tree commit diff
path: root/pkgs/test
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2004-03-12 11:12:18 +0000
committerEelco Dolstra <eelco.dolstra@logicblox.com>2004-03-12 11:12:18 +0000
commit0fd59fd7a41a47478f241b4a27c39d39f42914b9 (patch)
tree08c4488a5118b997c2721c8f793fd55028df2c73 /pkgs/test
parentde13527000165c566e47d2146a1a6480fc67da59 (diff)
downloadnixlib-0fd59fd7a41a47478f241b4a27c39d39f42914b9.tar
nixlib-0fd59fd7a41a47478f241b4a27c39d39f42914b9.tar.gz
nixlib-0fd59fd7a41a47478f241b4a27c39d39f42914b9.tar.bz2
nixlib-0fd59fd7a41a47478f241b4a27c39d39f42914b9.tar.lz
nixlib-0fd59fd7a41a47478f241b4a27c39d39f42914b9.tar.xz
nixlib-0fd59fd7a41a47478f241b4a27c39d39f42914b9.tar.zst
nixlib-0fd59fd7a41a47478f241b4a27c39d39f42914b9.zip
* Re-enabled purity checking: it should work now. First we only
  checked whether absolute paths passed to gcc/ld refer to the store,
  which is wrong: they can also refer to the build tree
  (/tmp/nix-...).

* Less static composition in the construction of stdenv-nix-linux:
  gcc-wrapper and generic are now passed in as arguments, rather then
  referenced by relative path.  This makes it easier to hack on a
  specific stage of the bootstrap process (before, a change to, e.g.,
  generic/setup.sh would cause all bootstrap stages to be redone).

svn path=/nixpkgs/trunk/; revision=833
Diffstat (limited to 'pkgs/test')
-rwxr-xr-xpkgs/test/simple/builder.sh7
-rw-r--r--pkgs/test/simple/default.nix2
2 files changed, 3 insertions, 6 deletions
diff --git a/pkgs/test/simple/builder.sh b/pkgs/test/simple/builder.sh
index cfc895ac1392..f97356a55630 100755
--- a/pkgs/test/simple/builder.sh
+++ b/pkgs/test/simple/builder.sh
@@ -6,10 +6,7 @@ export NIX_DEBUG=1
 
 . $stdenv/setup
 
-#echo starting shell
-#/bin/sh < /dev/tty > /dev/tty 2>&1 
-
-#exit 1
+export NIX_ENFORCE_PURITY=1
 
 mkdir $out
 mkdir $out/bin
@@ -25,7 +22,7 @@ int main(int argc, char * * argv)
 EOF
 
 #gcc -I/nix/store/foo -I /nix/store/foo -I/usr/lib -I /usr/lib hello.c -o $out/bin/hello
-gcc -L /nix/store/abcd/lib -isystem /usr/lib hello.c -o $out/bin/hello
+gcc -I`pwd` -L /nix/store/abcd/lib -isystem /usr/lib hello.c -o $out/bin/hello
 
 $out/bin/hello
 
diff --git a/pkgs/test/simple/default.nix b/pkgs/test/simple/default.nix
index 39b0416fc9a1..0201097dc7d3 100644
--- a/pkgs/test/simple/default.nix
+++ b/pkgs/test/simple/default.nix
@@ -6,7 +6,7 @@ let {
     allPackages = import ../../system/all-packages-generic.nix;
   };
 
-  stdenv = stdenvs.stdenvLinuxBoot2;
+  stdenv = stdenvs.stdenvLinux;
 
   test = derivation {
     name = "simple-test";