summary refs log tree commit diff
path: root/pkgs/system
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2004-03-29 17:23:01 +0000
committerEelco Dolstra <eelco.dolstra@logicblox.com>2004-03-29 17:23:01 +0000
commit12ae5363ea658d399bdb008f6ded3cde355f9310 (patch)
treee2a2ab3210854bfaad01f955c32b1cda724a8790 /pkgs/system
parentbc71554fc80a760c3a8e01f9e9e97500aa9ccde1 (diff)
downloadnixlib-12ae5363ea658d399bdb008f6ded3cde355f9310.tar
nixlib-12ae5363ea658d399bdb008f6ded3cde355f9310.tar.gz
nixlib-12ae5363ea658d399bdb008f6ded3cde355f9310.tar.bz2
nixlib-12ae5363ea658d399bdb008f6ded3cde355f9310.tar.lz
nixlib-12ae5363ea658d399bdb008f6ded3cde355f9310.tar.xz
nixlib-12ae5363ea658d399bdb008f6ded3cde355f9310.tar.zst
nixlib-12ae5363ea658d399bdb008f6ded3cde355f9310.zip
* Remove trivial builders.
* Make builders unexecutable by removing the hash-bang line and
  execute permission.
* Convert calls to `derivation' to `mkDerivation'.
* Remove `system' and `stdenv' attributes from calls to
  `mkDerivation'.  These transformations were all done automatically,
  so it is quite possible I broke stuff.
* Put the `mkDerivation' function in stdenv/generic.

svn path=/nixpkgs/trunk/; revision=874
Diffstat (limited to 'pkgs/system')
-rw-r--r--pkgs/system/stdenvs.nix19
1 files changed, 16 insertions, 3 deletions
diff --git a/pkgs/system/stdenvs.nix b/pkgs/system/stdenvs.nix
index 798091a9f2ed..0621608f2be3 100644
--- a/pkgs/system/stdenvs.nix
+++ b/pkgs/system/stdenvs.nix
@@ -23,7 +23,10 @@
   # i.e., the stuff in /bin, /usr/bin, etc.  This environment should
   # be used with care, since many Nix packages will not build properly
   # with it (e.g., because they require GNU Make).
-  stdenvNative = (import ../stdenv/native) {stdenv = stdenvInitial;};
+  stdenvNative = (import ../stdenv/native) {
+    stdenv = stdenvInitial;
+    inherit genericStdenv gccWrapper;
+  };
 
   stdenvNativePkgs = allPackages {
     stdenv = stdenvNative;
@@ -35,10 +38,20 @@
   # The Nix build environment.
   stdenvNix = (import ../stdenv/nix) {
     stdenv = stdenvNative;
-    pkgs = allPackages {stdenv = stdenvNative; noSysDirs = false;};
+    pkgs = stdenvNixBootPkgs;
+    inherit genericStdenv gccWrapper;
+  };
+
+  stdenvNixBootPkgs = allPackages {
+    stdenv = stdenvNative;
+    bootCurl = null;
+    noSysDirs = true;
   };
 
-  stdenvNixPkgs = allPackages {stdenv = stdenvNix;};
+  stdenvNixPkgs = allPackages {
+    stdenv = stdenvNix;
+    bootCurl = stdenvNixBootPkgs.curl;
+  };
 
 
   # The Linux build environment is a fully bootstrapped Nix