summary refs log tree commit diff
path: root/pkgs/stdenv
diff options
context:
space:
mode:
authorJohn Ericson <John.Ericson@Obsidian.Systems>2018-05-06 14:59:50 -0400
committerJohn Ericson <John.Ericson@Obsidian.Systems>2018-05-14 10:55:32 -0400
commiteebd455dc0bcc9f0d4fc8372811611ba3af18bcd (patch)
tree34fd5ff03dba0e226b0c8599e29ee0a992a4ea0a /pkgs/stdenv
parent29ef982af4f1af04981105159af8401f4f450c92 (diff)
downloadnixlib-eebd455dc0bcc9f0d4fc8372811611ba3af18bcd.tar
nixlib-eebd455dc0bcc9f0d4fc8372811611ba3af18bcd.tar.gz
nixlib-eebd455dc0bcc9f0d4fc8372811611ba3af18bcd.tar.bz2
nixlib-eebd455dc0bcc9f0d4fc8372811611ba3af18bcd.tar.lz
nixlib-eebd455dc0bcc9f0d4fc8372811611ba3af18bcd.tar.xz
nixlib-eebd455dc0bcc9f0d4fc8372811611ba3af18bcd.tar.zst
nixlib-eebd455dc0bcc9f0d4fc8372811611ba3af18bcd.zip
linux stdenv: Update gnu-config on all non-x86
Not just Aarch64. Other non-x86 platforms might be old enough, but I am
about to update gnu-config to handle things better across the board.
Diffstat (limited to 'pkgs/stdenv')
-rw-r--r--pkgs/stdenv/linux/default.nix8
1 files changed, 4 insertions, 4 deletions
diff --git a/pkgs/stdenv/linux/default.nix b/pkgs/stdenv/linux/default.nix
index 9e19d199a5da..63b4c8ecc244 100644
--- a/pkgs/stdenv/linux/default.nix
+++ b/pkgs/stdenv/linux/default.nix
@@ -255,7 +255,7 @@ in
     };
     extraNativeBuildInputs = [ prevStage.patchelf prevStage.paxctl ] ++
       # Many tarballs come with obsolete config.sub/config.guess that don't recognize aarch64.
-      lib.optional localSystem.isAarch64 prevStage.updateAutotoolsGnuConfigScriptsHook;
+      lib.optional (!localSystem.isx86) prevStage.updateAutotoolsGnuConfigScriptsHook;
   })
 
 
@@ -297,7 +297,7 @@ in
     };
     extraNativeBuildInputs = [ prevStage.patchelf prevStage.xz ] ++
       # Many tarballs come with obsolete config.sub/config.guess that don't recognize aarch64.
-      lib.optional localSystem.isAarch64 prevStage.updateAutotoolsGnuConfigScriptsHook;
+      lib.optional (!localSystem.isx86) prevStage.updateAutotoolsGnuConfigScriptsHook;
   })
 
   # Construct the final stdenv.  It uses the Glibc and GCC, and adds
@@ -327,7 +327,7 @@ in
 
       extraNativeBuildInputs = [ prevStage.patchelf prevStage.paxctl ] ++
         # Many tarballs come with obsolete config.sub/config.guess that don't recognize aarch64.
-        lib.optional localSystem.isAarch64 prevStage.updateAutotoolsGnuConfigScriptsHook;
+        lib.optional (!localSystem.isx86) prevStage.updateAutotoolsGnuConfigScriptsHook;
 
       cc = prevStage.gcc;
 
@@ -361,7 +361,7 @@ in
             binutils gcc gcc.cc gcc.cc.lib gcc.expand-response-params
           ]
           ++ lib.optional (localSystem.libc == "musl") libiconv
-          ++ lib.optionals localSystem.isAarch64
+          ++ lib.optionals (!localSystem.isx86)
             [ prevStage.updateAutotoolsGnuConfigScriptsHook prevStage.gnu-config ];
 
       overrides = self: super: {