summary refs log tree commit diff
path: root/pkgs/stdenv
diff options
context:
space:
mode:
authorJohn Ericson <Ericson2314@Yahoo.com>2017-05-22 12:42:03 -0400
committerJohn Ericson <Ericson2314@Yahoo.com>2017-05-22 13:55:26 -0400
commiteaa509f33a7058bd819f02a1da32c4ed372e6b49 (patch)
tree1e8612d7f14c6958ff4f45f8f8639d5b55e219d0 /pkgs/stdenv
parent1dc6f15de995da2d0351b34c40215336e219cf82 (diff)
downloadnixlib-eaa509f33a7058bd819f02a1da32c4ed372e6b49.tar
nixlib-eaa509f33a7058bd819f02a1da32c4ed372e6b49.tar.gz
nixlib-eaa509f33a7058bd819f02a1da32c4ed372e6b49.tar.bz2
nixlib-eaa509f33a7058bd819f02a1da32c4ed372e6b49.tar.lz
nixlib-eaa509f33a7058bd819f02a1da32c4ed372e6b49.tar.xz
nixlib-eaa509f33a7058bd819f02a1da32c4ed372e6b49.tar.zst
nixlib-eaa509f33a7058bd819f02a1da32c4ed372e6b49.zip
stdenv: Rename `isGNU` to `isHurd` as GNU is a userland
Elsewhere, things called GNU indeed includes GNU/Linux or GNU/Hurd, but this
predicate was defined excluding Linux regardless of userland.
Diffstat (limited to 'pkgs/stdenv')
-rw-r--r--pkgs/stdenv/generic/default.nix7
1 files changed, 2 insertions, 5 deletions
diff --git a/pkgs/stdenv/generic/default.nix b/pkgs/stdenv/generic/default.nix
index 0f9c4d7895d1..ceca0432f3ed 100644
--- a/pkgs/stdenv/generic/default.nix
+++ b/pkgs/stdenv/generic/default.nix
@@ -402,13 +402,10 @@ let
 
       # Utility flags to test the type of platform.
       inherit (hostPlatform)
-        isDarwin isLinux isSunOS isCygwin isFreeBSD isOpenBSD isi686 isx86_64
-        is64bit isMips isBigEndian;
+        isDarwin isLinux isSunOS isHurd isCygwin isFreeBSD isOpenBSD
+        isi686 isx86_64 is64bit isMips isBigEndian;
       isArm = hostPlatform.isArm32;
       isAarch64 = hostPlatform.isArm64;
-      # Other code instead checks for anything using GNU userland,
-      # e.g. GNU/linux. This refers just to GNU Hurd.
-      isGNU = system == "i686-gnu";
 
       # Whether we should run paxctl to pax-mark binaries.
       needsPax = isLinux;