summary refs log tree commit diff
path: root/pkgs/stdenv
diff options
context:
space:
mode:
authorDaiderd Jordan <daiderd@gmail.com>2018-08-14 23:02:04 +0200
committerGitHub <noreply@github.com>2018-08-14 23:02:04 +0200
commitea1542e9ee337281cd32c7d4295b63eacbeb9983 (patch)
treeffc4f5dc475d027cc11541b0acc0224180863c97 /pkgs/stdenv
parentded9a4b1aa68b8645271a63e9543ef56177ae642 (diff)
parent54f901d346b9df7f4506926160f0f378f0a79129 (diff)
downloadnixlib-ea1542e9ee337281cd32c7d4295b63eacbeb9983.tar
nixlib-ea1542e9ee337281cd32c7d4295b63eacbeb9983.tar.gz
nixlib-ea1542e9ee337281cd32c7d4295b63eacbeb9983.tar.bz2
nixlib-ea1542e9ee337281cd32c7d4295b63eacbeb9983.tar.lz
nixlib-ea1542e9ee337281cd32c7d4295b63eacbeb9983.tar.xz
nixlib-ea1542e9ee337281cd32c7d4295b63eacbeb9983.tar.zst
nixlib-ea1542e9ee337281cd32c7d4295b63eacbeb9983.zip
Merge pull request #43140 from LnL7/macos-10.14
darwin: fix Libsystem compatibility for macOS 10.14
Diffstat (limited to 'pkgs/stdenv')
-rw-r--r--pkgs/stdenv/darwin/make-bootstrap-tools.nix5
1 files changed, 4 insertions, 1 deletions
diff --git a/pkgs/stdenv/darwin/make-bootstrap-tools.nix b/pkgs/stdenv/darwin/make-bootstrap-tools.nix
index 6fc9d7f0c101..66c5f419f2f6 100644
--- a/pkgs/stdenv/darwin/make-bootstrap-tools.nix
+++ b/pkgs/stdenv/darwin/make-bootstrap-tools.nix
@@ -178,6 +178,9 @@ in rec {
   unpack = stdenv.mkDerivation (bootstrapFiles // {
     name = "unpack";
 
+    reexportedLibrariesFile =
+      ../../os-specific/darwin/apple-source-releases/Libsystem/reexported_libraries;
+
     # This is by necessity a near-duplicate of unpack-bootstrap-tools.sh. If we refer to it directly,
     # we can't make any changes to it due to our testing stdenv depending on it. Think of this as the
     # unpack-bootstrap-tools.sh for the next round of bootstrap tools.
@@ -209,7 +212,7 @@ in rec {
         $out/lib/system/libsystem_kernel.dylib
 
       # TODO: this logic basically duplicates similar logic in the Libsystem expression. Deduplicate them!
-      libs=$(otool -arch x86_64 -L /usr/lib/libSystem.dylib | tail -n +3 | awk '{ print $1 }')
+      libs=$(cat $reexportedLibrariesFile | grep -v '^#')
 
       for i in $libs; do
         if [ "$i" != "/usr/lib/system/libsystem_kernel.dylib" ] && [ "$i" != "/usr/lib/system/libsystem_c.dylib" ]; then