summary refs log tree commit diff
path: root/pkgs/stdenv
diff options
context:
space:
mode:
authorLluís Batlle i Rossell <viric@vicerveza.homeunix.net>2010-08-29 11:09:23 +0000
committerLluís Batlle i Rossell <viric@vicerveza.homeunix.net>2010-08-29 11:09:23 +0000
commitcca1cae0427deef621781ba3d9e9262bed50ee1a (patch)
tree044dfb0501637c25efa642ab3ba619bcfee3999f /pkgs/stdenv
parentdaa0f1335849b47d49bacb0592537223f868995e (diff)
parentce73a758aadc45358f6383ff25bb831ffa9ceb27 (diff)
downloadnixlib-cca1cae0427deef621781ba3d9e9262bed50ee1a.tar
nixlib-cca1cae0427deef621781ba3d9e9262bed50ee1a.tar.gz
nixlib-cca1cae0427deef621781ba3d9e9262bed50ee1a.tar.bz2
nixlib-cca1cae0427deef621781ba3d9e9262bed50ee1a.tar.lz
nixlib-cca1cae0427deef621781ba3d9e9262bed50ee1a.tar.xz
nixlib-cca1cae0427deef621781ba3d9e9262bed50ee1a.tar.zst
nixlib-cca1cae0427deef621781ba3d9e9262bed50ee1a.zip
Updating from trunk. I had to do some changes to make it fit.
svn path=/nixpkgs/branches/stdenv-updates/; revision=23500
Diffstat (limited to 'pkgs/stdenv')
-rw-r--r--pkgs/stdenv/generic/default.nix16
1 files changed, 13 insertions, 3 deletions
diff --git a/pkgs/stdenv/generic/default.nix b/pkgs/stdenv/generic/default.nix
index 2299c60c0818..7af6d2c0a55f 100644
--- a/pkgs/stdenv/generic/default.nix
+++ b/pkgs/stdenv/generic/default.nix
@@ -39,7 +39,7 @@ let
         meta = {
           description = "The default build environment for Unix packages in Nixpkgs";
         };
-    
+
         # Add a utility function to produce derivations that use this
         # stdenv and its shell.
         mkDerivation = attrs:
@@ -90,7 +90,9 @@ let
           (if attrs ? passthru then attrs.passthru else {});
 
         # Utility flags to test the type of platform.
-        isDarwin = result.system == "i686-darwin" || result.system == "powerpc-darwin" || result.system == "x86_64-darwin";
+        isDarwin = result.system == "i686-darwin"
+	       || result.system == "powerpc-darwin"
+	       || result.system == "x86_64-darwin";
         isLinux = result.system == "i686-linux"
                || result.system == "x86_64-linux"
                || result.system == "powerpc-linux"
@@ -98,6 +100,14 @@ let
                || result.system == "ict_loongson-2_v0.3_fpu_v0.1-linux";
         isSunOS = result.system == "i386-sunos";
         isCygwin = result.system == "i686-cygwin";
+	isFreeBSD = result.system == "i686-freebsd"
+	       || result.system == "x86_64-freebsd";
+	isOpenBSD = result.system == "i686-openbsd"
+	       || result.system == "x86_64-openbsd";
+	isBSD = result.system == "i686-freebsd"
+	       || result.system == "x86_64-freebsd"
+	       || result.system == "i686-openbsd"
+	       || result.system == "x86_64-openbsd";
         isi686 = result.system == "i686-linux"
                || result.system == "i686-darwin"
                || result.system == "i686-freebsd"
@@ -136,5 +146,5 @@ let
 
   }.result;
 
-  
+
 in stdenvGenerator ./setup.sh