summary refs log tree commit diff
path: root/pkgs/stdenv
diff options
context:
space:
mode:
authorTuomas Tynkkynen <tuomas@tuxera.com>2017-01-05 00:46:34 +0200
committerTuomas Tynkkynen <tuomas@tuxera.com>2017-01-05 00:55:35 +0200
commitbde863210687e6afa43d12a04e7119fb490acc52 (patch)
treedc1d8459dd904d3a67207604c71e7511d85cd8dd /pkgs/stdenv
parentea7b252c9ae0117b8f150950d730a7445d3f5e2d (diff)
downloadnixlib-bde863210687e6afa43d12a04e7119fb490acc52.tar
nixlib-bde863210687e6afa43d12a04e7119fb490acc52.tar.gz
nixlib-bde863210687e6afa43d12a04e7119fb490acc52.tar.bz2
nixlib-bde863210687e6afa43d12a04e7119fb490acc52.tar.lz
nixlib-bde863210687e6afa43d12a04e7119fb490acc52.tar.xz
nixlib-bde863210687e6afa43d12a04e7119fb490acc52.tar.zst
nixlib-bde863210687e6afa43d12a04e7119fb490acc52.zip
coreutils: Build with libattr to support xattrs
Fixes #21649
Diffstat (limited to 'pkgs/stdenv')
-rw-r--r--pkgs/stdenv/linux/make-bootstrap-tools-cross.nix3
-rw-r--r--pkgs/stdenv/linux/make-bootstrap-tools.nix3
2 files changed, 4 insertions, 2 deletions
diff --git a/pkgs/stdenv/linux/make-bootstrap-tools-cross.nix b/pkgs/stdenv/linux/make-bootstrap-tools-cross.nix
index af82788d3fa9..9f4a4517627e 100644
--- a/pkgs/stdenv/linux/make-bootstrap-tools-cross.nix
+++ b/pkgs/stdenv/linux/make-bootstrap-tools-cross.nix
@@ -87,8 +87,9 @@ rec {
 
 
   coreutilsMinimal = (pkgs.coreutils.override (args: {
-    # We want coreutils without ACL support.
+    # We want coreutils without ACL/attr support.
     aclSupport = false;
+    attrSupport = false;
     # Our tooling currently can't handle scripts in bin/, only ELFs and symlinks.
     singleBinary = "symlinks";
   })).crossDrv;
diff --git a/pkgs/stdenv/linux/make-bootstrap-tools.nix b/pkgs/stdenv/linux/make-bootstrap-tools.nix
index e13fb88eff0b..d31253075c9d 100644
--- a/pkgs/stdenv/linux/make-bootstrap-tools.nix
+++ b/pkgs/stdenv/linux/make-bootstrap-tools.nix
@@ -6,8 +6,9 @@ rec {
 
 
   coreutilsMinimal = coreutils.override (args: {
-    # We want coreutils without ACL support.
+    # We want coreutils without ACL/attr support.
     aclSupport = false;
+    attrSupport = false;
     # Our tooling currently can't handle scripts in bin/, only ELFs and symlinks.
     singleBinary = "symlinks";
   });