summary refs log tree commit diff
path: root/pkgs/stdenv
diff options
context:
space:
mode:
authorLluís Batlle i Rossell <viric@vicerveza.homeunix.net>2010-08-23 19:59:06 +0000
committerLluís Batlle i Rossell <viric@vicerveza.homeunix.net>2010-08-23 19:59:06 +0000
commit643eb3435e9033aa5500907830c941ce29ac4992 (patch)
tree98d6fef3dd69e39654e7f64467b02e614b26f23e /pkgs/stdenv
parentcdbe8d495c7e82a358b3a410d57f8145ac678903 (diff)
downloadnixlib-643eb3435e9033aa5500907830c941ce29ac4992.tar
nixlib-643eb3435e9033aa5500907830c941ce29ac4992.tar.gz
nixlib-643eb3435e9033aa5500907830c941ce29ac4992.tar.bz2
nixlib-643eb3435e9033aa5500907830c941ce29ac4992.tar.lz
nixlib-643eb3435e9033aa5500907830c941ce29ac4992.tar.xz
nixlib-643eb3435e9033aa5500907830c941ce29ac4992.tar.zst
nixlib-643eb3435e9033aa5500907830c941ce29ac4992.zip
Moving back my attempt to build binutils before glibc in stdenvLinux.
What I did results in segfaults in built binaries.

svn merge -c -23370 ^/nixpkgs/branches/stdenv-updates


svn path=/nixpkgs/branches/stdenv-updates/; revision=23376
Diffstat (limited to 'pkgs/stdenv')
-rw-r--r--pkgs/stdenv/linux/default.nix26
1 files changed, 3 insertions, 23 deletions
diff --git a/pkgs/stdenv/linux/default.nix b/pkgs/stdenv/linux/default.nix
index 5cc6d4277f34..5654a8ccaf58 100644
--- a/pkgs/stdenv/linux/default.nix
+++ b/pkgs/stdenv/linux/default.nix
@@ -160,30 +160,10 @@ rec {
     bootStdenv = stdenvLinuxBoot1;
   };
 
-  # Create the first "real" standard environment.  This one consists
-  # of bootstrap tools only, and a minimal Glibc to keep the GCC
-  # configure script happy.
-  stdenvLinuxBoot1half = stdenvBootFun {
-    gcc = wrapGCC {
-      libc = bootstrapGlibc;
-      binutils = stdenvLinuxBoot1Pkgs.binutils;
-      coreutils = bootstrapTools;
-    };
-    inherit fetchurl;
-  };
-  
-
-  # 2) These are the packages that we can build with the first
-  #    stdenv.  We only need Glibc (in step 3).
-  stdenvLinuxBoot1halfPkgs = allPackages {
-    inherit system platform;
-    bootStdenv = stdenvLinuxBoot1half;
-  };
-
   
   # 3) Build Glibc with the bootstrap tools.  The result is the full,
   #    dynamically linked, final Glibc.
-  stdenvLinuxGlibc = stdenvLinuxBoot1halfPkgs.glibc;
+  stdenvLinuxGlibc = stdenvLinuxBoot1Pkgs.glibc;
 
   
   # 4) Construct a second stdenv identical to the first, except that
@@ -197,7 +177,7 @@ rec {
     };
     overrides = {
       glibc = stdenvLinuxGlibc;
-      inherit (stdenvLinuxBoot1halfPkgs) perl;
+      inherit (stdenvLinuxBoot1Pkgs) perl;
     };
     inherit fetchurl;
   }) ["gcc" "binutils"];
@@ -235,7 +215,7 @@ rec {
       name = "";
     };
     overrides = {
-      inherit (stdenvLinuxBoot1halfPkgs) perl;
+      inherit (stdenvLinuxBoot1Pkgs) perl;
     };
     inherit fetchurl;
   };