summary refs log tree commit diff
path: root/pkgs/stdenv
diff options
context:
space:
mode:
authorAnthony Cowley <acowley@gmail.com>2016-01-24 00:18:32 -0500
committerAnthony Cowley <acowley@gmail.com>2016-01-24 00:18:32 -0500
commit5986aecc4c4e3d99d815da1ef7ea4ed2092f221e (patch)
tree9c26fc6049c3ea2f195db083b452944b807f6b08 /pkgs/stdenv
parentd96893647de5c519c458c1254f043f2d67d9b29c (diff)
downloadnixlib-5986aecc4c4e3d99d815da1ef7ea4ed2092f221e.tar
nixlib-5986aecc4c4e3d99d815da1ef7ea4ed2092f221e.tar.gz
nixlib-5986aecc4c4e3d99d815da1ef7ea4ed2092f221e.tar.bz2
nixlib-5986aecc4c4e3d99d815da1ef7ea4ed2092f221e.tar.lz
nixlib-5986aecc4c4e3d99d815da1ef7ea4ed2092f221e.tar.xz
nixlib-5986aecc4c4e3d99d815da1ef7ea4ed2092f221e.tar.zst
nixlib-5986aecc4c4e3d99d815da1ef7ea4ed2092f221e.zip
Linux stdenv update: pass gnugrep to cc-wrapper
Diffstat (limited to 'pkgs/stdenv')
-rw-r--r--pkgs/stdenv/linux/default.nix12
1 files changed, 8 insertions, 4 deletions
diff --git a/pkgs/stdenv/linux/default.nix b/pkgs/stdenv/linux/default.nix
index 12fc3fed5a5a..4ddf62f0aef7 100644
--- a/pkgs/stdenv/linux/default.nix
+++ b/pkgs/stdenv/linux/default.nix
@@ -64,7 +64,7 @@ rec {
   # the bootstrap.  In all stages, we build an stdenv and the package
   # set that can be built with that stdenv.
   stageFun =
-    {gccPlain, glibc, binutils, coreutils, name, overrides ? (pkgs: {}), extraBuildInputs ? []}:
+    {gccPlain, glibc, binutils, coreutils, gnugrep, name, overrides ? (pkgs: {}), extraBuildInputs ? []}:
 
     let
 
@@ -93,7 +93,7 @@ rec {
           cc = gccPlain;
           isGNU = true;
           libc = glibc;
-          inherit binutils coreutils;
+          inherit binutils coreutils gnugrep;
           name = name;
           stdenv = stage0.stdenv;
         };
@@ -125,6 +125,7 @@ rec {
     glibc = null;
     binutils = null;
     coreutils = null;
+    gnugrep = null;
     name = null;
 
     overrides = pkgs: {
@@ -160,6 +161,7 @@ rec {
     inherit (stage0.pkgs) glibc;
     binutils = bootstrapTools;
     coreutils = bootstrapTools;
+    gnugrep = bootstrapTools;
     name = "bootstrap-gcc-wrapper";
 
     # Rebuild binutils to use from stage2 onwards.
@@ -184,6 +186,7 @@ rec {
     inherit (stage1.pkgs) glibc;
     binutils = stage1.pkgs.binutils;
     coreutils = bootstrapTools;
+    gnugrep = bootstrapTools;
     name = "bootstrap-gcc-wrapper";
 
     overrides = pkgs: {
@@ -200,6 +203,7 @@ rec {
     gccPlain = bootstrapTools;
     inherit (stage2.pkgs) glibc binutils;
     coreutils = bootstrapTools;
+    gnugrep = bootstrapTools;
     name = "bootstrap-gcc-wrapper";
 
     overrides = pkgs: rec {
@@ -227,7 +231,7 @@ rec {
   # Construct a fourth stdenv that uses the new GCC.  But coreutils is
   # still from the bootstrap tools.
   stage4 = stageFun {
-    inherit (stage3.pkgs) gccPlain glibc binutils;
+    inherit (stage3.pkgs) gccPlain glibc binutils gnugrep;
     coreutils = bootstrapTools;
     name = "";
 
@@ -244,7 +248,7 @@ rec {
         isGNU = true;
         cc = stage4.stdenv.cc.cc;
         libc = stage4.pkgs.glibc;
-        inherit (stage4.pkgs) binutils coreutils;
+        inherit (stage4.pkgs) binutils coreutils gnugrep;
         name = "";
         stdenv = stage4.stdenv;
         shell = stage4.pkgs.bash + "/bin/bash";