summary refs log tree commit diff
path: root/pkgs/stdenv
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2016-02-28 01:12:58 +0100
committerEelco Dolstra <eelco.dolstra@logicblox.com>2016-02-28 01:12:58 +0100
commit559ecc92127873d2075dc1c24dad986bc1ff868a (patch)
tree0cc1f8fc6bf12c175a16e6d3f3ba1159c5cf4e8e /pkgs/stdenv
parent817145ebbce3c69f0ace4f356103514b5b601bec (diff)
downloadnixlib-559ecc92127873d2075dc1c24dad986bc1ff868a.tar
nixlib-559ecc92127873d2075dc1c24dad986bc1ff868a.tar.gz
nixlib-559ecc92127873d2075dc1c24dad986bc1ff868a.tar.bz2
nixlib-559ecc92127873d2075dc1c24dad986bc1ff868a.tar.lz
nixlib-559ecc92127873d2075dc1c24dad986bc1ff868a.tar.xz
nixlib-559ecc92127873d2075dc1c24dad986bc1ff868a.tar.zst
nixlib-559ecc92127873d2075dc1c24dad986bc1ff868a.zip
stdenv-linux: Avoid building m4/bison twice
Diffstat (limited to 'pkgs/stdenv')
-rw-r--r--pkgs/stdenv/linux/default.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/pkgs/stdenv/linux/default.nix b/pkgs/stdenv/linux/default.nix
index 965188a0cdd8..2aa32bec85e6 100644
--- a/pkgs/stdenv/linux/default.nix
+++ b/pkgs/stdenv/linux/default.nix
@@ -190,7 +190,7 @@ rec {
     name = "bootstrap-gcc-wrapper";
 
     overrides = pkgs: {
-      inherit (stage1.pkgs) perl binutils paxctl;
+      inherit (stage1.pkgs) perl binutils paxctl gnum4 bison;
       # This also contains the full, dynamically linked, final Glibc.
     };
   };
@@ -207,7 +207,7 @@ rec {
     name = "bootstrap-gcc-wrapper";
 
     overrides = pkgs: rec {
-      inherit (stage2.pkgs) binutils glibc perl patchelf linuxHeaders;
+      inherit (stage2.pkgs) binutils glibc perl patchelf linuxHeaders gnum4 bison;
       # Link GCC statically against GMP etc.  This makes sense because
       # these builds of the libraries are only used by GCC, so it
       # reduces the size of the stdenv closure.
@@ -241,7 +241,7 @@ rec {
       # because gcc (since JAR support) already depends on zlib, and
       # then if we already have a zlib we want to use that for the
       # other purposes (binutils and top-level pkgs) too.
-      inherit (stage3.pkgs) gettext gnum4 gmp perl glibc zlib linuxHeaders;
+      inherit (stage3.pkgs) gettext gnum4 bison gmp perl glibc zlib linuxHeaders;
 
       gcc = lib.makeOverridable (import ../../build-support/cc-wrapper) {
         nativeTools = false;