summary refs log tree commit diff
path: root/pkgs/stdenv
diff options
context:
space:
mode:
authorJohn Ericson <John.Ericson@Obsidian.Systems>2018-01-08 01:33:35 -0500
committerJohn Ericson <John.Ericson@Obsidian.Systems>2018-01-09 12:37:12 -0500
commit4e907dbca19d4b1ab6b110c7e68f88a539df7c97 (patch)
tree10e75d40dfaaae0882d8bf1003c1c09d2afb566e /pkgs/stdenv
parentb2cbffae6468c34f3c315bc40aa6df4483309f00 (diff)
downloadnixlib-4e907dbca19d4b1ab6b110c7e68f88a539df7c97.tar
nixlib-4e907dbca19d4b1ab6b110c7e68f88a539df7c97.tar.gz
nixlib-4e907dbca19d4b1ab6b110c7e68f88a539df7c97.tar.bz2
nixlib-4e907dbca19d4b1ab6b110c7e68f88a539df7c97.tar.lz
nixlib-4e907dbca19d4b1ab6b110c7e68f88a539df7c97.tar.xz
nixlib-4e907dbca19d4b1ab6b110c7e68f88a539df7c97.tar.zst
nixlib-4e907dbca19d4b1ab6b110c7e68f88a539df7c97.zip
stdenv: Force `doCheck` and `doInstallCheck` to be false when we are cross compiling
I hope this will be a temporary measure. If there is consensus around
issue #33599, then we can follow an explicit `dontCheck`, but default to
not checking during cross builds when none is given.
Diffstat (limited to 'pkgs/stdenv')
-rw-r--r--pkgs/stdenv/generic/make-derivation.nix19
1 files changed, 17 insertions, 2 deletions
diff --git a/pkgs/stdenv/generic/make-derivation.nix b/pkgs/stdenv/generic/make-derivation.nix
index 2d702ab389e6..3ffa7cfe35fc 100644
--- a/pkgs/stdenv/generic/make-derivation.nix
+++ b/pkgs/stdenv/generic/make-derivation.nix
@@ -36,6 +36,7 @@ rec {
     , depsTargetTarget            ? [] #  1 ->  1
     , depsTargetTargetPropagated  ? [] #  1 ->  1
 
+    # Configure Phase
     , configureFlags ? []
     , # Target is not included by default because most programs don't care.
       # Including it then would cause needless mass rebuilds.
@@ -44,6 +45,13 @@ rec {
       configurePlatforms ? lib.optionals
         (stdenv.hostPlatform != stdenv.buildPlatform)
         [ "build" "host" ]
+
+    # Check phase
+    , doCheck ? false
+
+    # InstallCheck phase
+    , doInstallCheck ? false
+
     , crossConfig ? null
     , meta ? {}
     , passthru ? {}
@@ -60,6 +68,7 @@ rec {
 
     , hardeningEnable ? []
     , hardeningDisable ? []
+
     , ... } @ attrs:
 
     # TODO(@Ericson2314): Make this more modular, and not O(n^2).
@@ -178,9 +187,15 @@ rec {
             "/bin/sh"
           ];
           __propagatedImpureHostDeps = computedPropagatedImpureHostDeps ++ __propagatedImpureHostDeps;
-        } // (if outputs' != [ "out" ] then {
+        } // lib.optionalAttrs (outputs' != [ "out" ]) {
           outputs = outputs';
-        } else { }));
+        } // lib.optionalAttrs (attrs ? doCheck) {
+          # TODO(@Ericson2314): Make unconditional / resolve #33599
+          doCheck = doCheck && (stdenv.hostPlatform == stdenv.targetPlatform);
+        } // lib.optionalAttrs (attrs ? doInstallCheck) {
+          # TODO(@Ericson2314): Make unconditional / resolve #33599
+          doInstallCheck = doInstallCheck && (stdenv.hostPlatform == stdenv.targetPlatform);
+        });
 
       # The meta attribute is passed in the resulting attribute set,
       # but it's not part of the actual derivation, i.e., it's not