summary refs log tree commit diff
path: root/pkgs/stdenv
diff options
context:
space:
mode:
authorJohn Ericson <Ericson2314@Yahoo.com>2017-02-13 18:01:04 -0500
committerJohn Ericson <John.Ericson@Obsidian.Systems>2017-06-22 17:52:27 -0400
commit459f1c60f5e53acb96123a7da8463d1e21093426 (patch)
tree06e08a7d7f100469d611b689e7e4cfeb05b01ae4 /pkgs/stdenv
parentc4ba2e3ef691c349bcce2b1e8b76a0bcd253544c (diff)
downloadnixlib-459f1c60f5e53acb96123a7da8463d1e21093426.tar
nixlib-459f1c60f5e53acb96123a7da8463d1e21093426.tar.gz
nixlib-459f1c60f5e53acb96123a7da8463d1e21093426.tar.bz2
nixlib-459f1c60f5e53acb96123a7da8463d1e21093426.tar.lz
nixlib-459f1c60f5e53acb96123a7da8463d1e21093426.tar.xz
nixlib-459f1c60f5e53acb96123a7da8463d1e21093426.tar.zst
nixlib-459f1c60f5e53acb96123a7da8463d1e21093426.zip
cc-wrapper: Learn about target prefixes
This is first step towards getting rid of gcc-wrapper-cross
Diffstat (limited to 'pkgs/stdenv')
-rw-r--r--pkgs/stdenv/darwin/default.nix2
-rw-r--r--pkgs/stdenv/freebsd/default.nix1
-rw-r--r--pkgs/stdenv/linux/default.nix2
-rw-r--r--pkgs/stdenv/native/default.nix1
-rw-r--r--pkgs/stdenv/nix/default.nix1
5 files changed, 7 insertions, 0 deletions
diff --git a/pkgs/stdenv/darwin/default.nix b/pkgs/stdenv/darwin/default.nix
index 1592426b6e39..bce332b67616 100644
--- a/pkgs/stdenv/darwin/default.nix
+++ b/pkgs/stdenv/darwin/default.nix
@@ -73,6 +73,7 @@ in rec {
           nativeTools  = true;
           nativePrefix = bootstrapTools;
           nativeLibc   = false;
+          hostPlatform = localSystem;
           targetPlatform = localSystem;
           libc         = last.pkgs.darwin.Libsystem;
           isClang      = true;
@@ -296,6 +297,7 @@ in rec {
       inherit shell;
       nativeTools = false;
       nativeLibc  = false;
+      hostPlatform = localSystem;
       targetPlatform = localSystem;
       inherit (pkgs) coreutils binutils gnugrep;
       inherit (pkgs.darwin) dyld;
diff --git a/pkgs/stdenv/freebsd/default.nix b/pkgs/stdenv/freebsd/default.nix
index 20be86e5f963..389a5b9985fe 100644
--- a/pkgs/stdenv/freebsd/default.nix
+++ b/pkgs/stdenv/freebsd/default.nix
@@ -77,6 +77,7 @@ let inherit (localSystem) system; in
         nativeTools  = true;
         nativePrefix = "/usr";
         nativeLibc   = true;
+        hostPlatform = localSystem;
         targetPlatform = localSystem;
         inherit (prevStage) stdenv;
         cc           = {
diff --git a/pkgs/stdenv/linux/default.nix b/pkgs/stdenv/linux/default.nix
index b23d1cd01737..b116a48a2bd6 100644
--- a/pkgs/stdenv/linux/default.nix
+++ b/pkgs/stdenv/linux/default.nix
@@ -76,6 +76,7 @@ let
              else lib.makeOverridable (import ../../build-support/cc-wrapper) {
           nativeTools = false;
           nativeLibc = false;
+          hostPlatform = localSystem;
           targetPlatform = localSystem;
           cc = prevStage.gcc-unwrapped;
           isGNU = true;
@@ -240,6 +241,7 @@ in
         nativeTools = false;
         nativeLibc = false;
         isGNU = true;
+        hostPlatform = localSystem;
         targetPlatform = localSystem;
         cc = prevStage.gcc-unwrapped;
         libc = self.glibc;
diff --git a/pkgs/stdenv/native/default.nix b/pkgs/stdenv/native/default.nix
index 3bcd0687bc6e..b21da1cd522b 100644
--- a/pkgs/stdenv/native/default.nix
+++ b/pkgs/stdenv/native/default.nix
@@ -125,6 +125,7 @@ in
         "i686-solaris" = "/usr/gnu";
         "x86_64-solaris" = "/opt/local/gcc47";
       }.${system} or "/usr";
+      hostPlatform = localSystem;
       targetPlatform = localSystem;
       inherit stdenv;
     };
diff --git a/pkgs/stdenv/nix/default.nix b/pkgs/stdenv/nix/default.nix
index 2363fb966e7a..7ab797ce91ba 100644
--- a/pkgs/stdenv/nix/default.nix
+++ b/pkgs/stdenv/nix/default.nix
@@ -30,6 +30,7 @@ bootStages ++ [
         nativeTools = false;
         nativePrefix = stdenv.lib.optionalString hostPlatform.isSunOS "/usr";
         nativeLibc = true;
+        hostPlatform = localSystem;
         targetPlatform = localSystem;
         inherit stdenv;
         inherit (prevStage) binutils coreutils gnugrep;