summary refs log tree commit diff
path: root/pkgs/stdenv
diff options
context:
space:
mode:
authorThomas Tuegel <ttuegel@gmail.com>2016-02-01 11:16:50 -0600
committerThomas Tuegel <ttuegel@gmail.com>2016-03-08 11:35:24 -0600
commit3ef7671cea0ed5a4819e1cd83c03f4ee1f85eb96 (patch)
tree4d31f367269d63a1f3c4d1314e50901396f8850c /pkgs/stdenv
parent394ffcb3e5a89690588319eb995d3e066a1f2f89 (diff)
downloadnixlib-3ef7671cea0ed5a4819e1cd83c03f4ee1f85eb96.tar
nixlib-3ef7671cea0ed5a4819e1cd83c03f4ee1f85eb96.tar.gz
nixlib-3ef7671cea0ed5a4819e1cd83c03f4ee1f85eb96.tar.bz2
nixlib-3ef7671cea0ed5a4819e1cd83c03f4ee1f85eb96.tar.lz
nixlib-3ef7671cea0ed5a4819e1cd83c03f4ee1f85eb96.tar.xz
nixlib-3ef7671cea0ed5a4819e1cd83c03f4ee1f85eb96.tar.zst
nixlib-3ef7671cea0ed5a4819e1cd83c03f4ee1f85eb96.zip
ncurses: combine $lib and $out outputs
The $lib output refers to the terminfo database in $out, which is about
10x larger than the ncurses shared library. Splitting these outputs
saves a small amount of space for any derivations that use the terminfo
database but not the ncurses library, but we do not have evidence that
any such exist.
Diffstat (limited to 'pkgs/stdenv')
-rw-r--r--pkgs/stdenv/darwin/default.nix2
-rw-r--r--pkgs/stdenv/darwin/make-bootstrap-tools.nix2
2 files changed, 2 insertions, 2 deletions
diff --git a/pkgs/stdenv/darwin/default.nix b/pkgs/stdenv/darwin/default.nix
index 810031809173..16e35d19db0d 100644
--- a/pkgs/stdenv/darwin/default.nix
+++ b/pkgs/stdenv/darwin/default.nix
@@ -296,7 +296,7 @@ in rec {
     allowedRequisites = (with pkgs; [
       xz.out xz.bin libcxx libcxxabi icu.out gmp.out gnumake findutils bzip2.out
       bzip2.bin llvm zlib.out zlib.dev libffi.out coreutils ed diffutils gnutar
-      gzip ncurses.out ncurses.dev ncurses.lib ncurses.man gnused bash gawk
+      gzip ncurses.out ncurses.dev ncurses.man gnused bash gawk
       gnugrep llvmPackages.clang-unwrapped patch pcre.out binutils-raw.out
       binutils-raw.dev binutils gettext
     ]) ++ (with pkgs.darwin; [
diff --git a/pkgs/stdenv/darwin/make-bootstrap-tools.nix b/pkgs/stdenv/darwin/make-bootstrap-tools.nix
index dc52015c52dc..32b779689deb 100644
--- a/pkgs/stdenv/darwin/make-bootstrap-tools.nix
+++ b/pkgs/stdenv/darwin/make-bootstrap-tools.nix
@@ -65,7 +65,7 @@ rec {
       cp -d ${libiconv.lib}/lib/lib*.dylib $out/lib
       cp -d ${gettext}/lib/libintl*.dylib $out/lib
       chmod +x $out/lib/libintl*.dylib
-      cp -d ${ncurses.lib}/lib/libncurses*.dylib $out/lib
+      cp -d ${ncurses.out}/lib/libncurses*.dylib $out/lib
 
       # Copy what we need of clang
       cp -d ${llvmPackages.clang-unwrapped}/bin/clang $out/bin