summary refs log tree commit diff
path: root/pkgs/stdenv
diff options
context:
space:
mode:
authorThomas Tuegel <ttuegel@gmail.com>2016-10-06 09:51:02 -0500
committerThomas Tuegel <ttuegel@gmail.com>2016-10-06 09:51:02 -0500
commit2e255a2edddfe5ca0e44f55d6e4bd82737cbb884 (patch)
treec785d80650dc2d074244525401246fc6ef07a468 /pkgs/stdenv
parente3deccc0d7a42b0ae1d5e337cd6b0b9488c2295a (diff)
parent16dafb018e09363bfae3949a8261c18ee7880781 (diff)
downloadnixlib-2e255a2edddfe5ca0e44f55d6e4bd82737cbb884.tar
nixlib-2e255a2edddfe5ca0e44f55d6e4bd82737cbb884.tar.gz
nixlib-2e255a2edddfe5ca0e44f55d6e4bd82737cbb884.tar.bz2
nixlib-2e255a2edddfe5ca0e44f55d6e4bd82737cbb884.tar.lz
nixlib-2e255a2edddfe5ca0e44f55d6e4bd82737cbb884.tar.xz
nixlib-2e255a2edddfe5ca0e44f55d6e4bd82737cbb884.tar.zst
nixlib-2e255a2edddfe5ca0e44f55d6e4bd82737cbb884.zip
Merge branch 'staging'
Diffstat (limited to 'pkgs/stdenv')
-rw-r--r--pkgs/stdenv/darwin/default.nix14
1 files changed, 7 insertions, 7 deletions
diff --git a/pkgs/stdenv/darwin/default.nix b/pkgs/stdenv/darwin/default.nix
index 09d9ed23b3f8..b530b7578e8e 100644
--- a/pkgs/stdenv/darwin/default.nix
+++ b/pkgs/stdenv/darwin/default.nix
@@ -6,14 +6,14 @@
 # Allow passing in bootstrap files directly so we can test the stdenv bootstrap process when changing the bootstrap tools
 , bootstrapFiles ? let
   fetch = { file, sha256, executable ? true }: import <nix/fetchurl.nix> {
-    url = "http://tarballs.nixos.org/stdenv-darwin/x86_64/4f07c88d467216d9692fefc951deb5cd3c4cc722/${file}";
+    url = "http://tarballs.nixos.org/stdenv-darwin/x86_64/62540508837664e9b366e36d1265502db4329a6e/${file}";
     inherit sha256 system executable;
   }; in {
-    sh      = fetch { file = "sh";    sha256 = "1siix3wakzil31r2cydmh3v8a1nyq4605dwiabqc5lx73j4xzrzi"; };
-    bzip2   = fetch { file = "bzip2"; sha256 = "0zvqm977k11b5cl4ixxb5h0ds24g6z0f8m28z4pqxzpa353lqbla"; };
-    mkdir   = fetch { file = "mkdir"; sha256 = "13frk8lsfgzlb65p9l26cvxf06aag43yjk7vg9msn7ix3v8cmrg1"; };
-    cpio    = fetch { file = "cpio";  sha256 = "0ms5i9m1vdksj575sf1djwgm7zhnvfrrb44dxnfh9avr793rc2w4"; };
-    tarball = fetch { file = "bootstrap-tools.cpio.bz2"; sha256 = "1lz1b0grl4642h6n635xvi6imf0yyy1zyzdr9ing5aphzz0z5iic"; executable = false; };
+    sh      = fetch { file = "sh";    sha256 = "1qpg16qbqqkmcr5an4d73p6q55izhlzmdd3nvid8gp7f3f9spbz7"; };
+    bzip2   = fetch { file = "bzip2"; sha256 = "1g67sh51fa2ws9wch5gznvrmmh27mks3dbnp6gvac43qxdnv6mpz"; };
+    mkdir   = fetch { file = "mkdir"; sha256 = "1lkp6y33lsrj9yif1cfrw5g021pffynrdscrz3ds19hslg55w4dw"; };
+    cpio    = fetch { file = "cpio";  sha256 = "115pgrl0pcq2h4yfqrmfvffl0dcabw4mgkc91aphd913wrzfmlz9"; };
+    tarball = fetch { file = "bootstrap-tools.cpio.bz2"; sha256 = "1ak16xrj41l15ads5l2kfgbyrb1lczzhmi8nln5h0np8r3w9frw9"; executable = false; };
   }
 }:
 
@@ -128,7 +128,7 @@ in rec {
           ln -s ${bootstrapTools}/include/c++      $out/include/c++
         '';
         linkCxxAbi = false;
-        setupHook = ../../development/compilers/llvm/3.6/libc++/setup-hook.sh;
+        setupHook = ../../development/compilers/llvm/3.9/libc++/setup-hook.sh;
       };
 
       libcxxabi = stdenv.mkDerivation {