summary refs log tree commit diff
path: root/pkgs/stdenv
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2010-01-19 11:25:33 +0000
committerEelco Dolstra <eelco.dolstra@logicblox.com>2010-01-19 11:25:33 +0000
commit231b016142c78b1be90a6e0757b0ed580b3c03bb (patch)
tree301f07154897b16d3a40d9b160360b7dbcebd179 /pkgs/stdenv
parentca0464c067f2651cd925dc3b8e1b8db2d9c07141 (diff)
downloadnixlib-231b016142c78b1be90a6e0757b0ed580b3c03bb.tar
nixlib-231b016142c78b1be90a6e0757b0ed580b3c03bb.tar.gz
nixlib-231b016142c78b1be90a6e0757b0ed580b3c03bb.tar.bz2
nixlib-231b016142c78b1be90a6e0757b0ed580b3c03bb.tar.lz
nixlib-231b016142c78b1be90a6e0757b0ed580b3c03bb.tar.xz
nixlib-231b016142c78b1be90a6e0757b0ed580b3c03bb.tar.zst
nixlib-231b016142c78b1be90a6e0757b0ed580b3c03bb.zip
* During the bootstrap, build only 1 instance of Perl instead of 3.
svn path=/nixpkgs/branches/stdenv-updates/; revision=19536
Diffstat (limited to 'pkgs/stdenv')
-rw-r--r--pkgs/stdenv/linux/default.nix23
1 files changed, 18 insertions, 5 deletions
diff --git a/pkgs/stdenv/linux/default.nix b/pkgs/stdenv/linux/default.nix
index e04b81b152b2..dd5647bec456 100644
--- a/pkgs/stdenv/linux/default.nix
+++ b/pkgs/stdenv/linux/default.nix
@@ -137,8 +137,11 @@ rec {
   # of bootstrap tools only, and a minimal Glibc to keep the GCC
   # configure script happy.
   stdenvLinuxBoot1 = stdenvBootFun {
-    gcc = wrapGCC {libc = bootstrapGlibc; binutils = bootstrapTools;
-      coreutils = bootstrapTools; };
+    gcc = wrapGCC {
+      libc = bootstrapGlibc;
+      binutils = bootstrapTools;
+      coreutils = bootstrapTools;
+    };
     inherit fetchurl;
   };
   
@@ -160,9 +163,15 @@ rec {
   #    this one uses the Glibc built in step 3.  It still uses
   #    the rest of the bootstrap tools, including GCC.
   stdenvLinuxBoot2 = removeAttrs (stdenvBootFun {
-    gcc = wrapGCC {binutils = bootstrapTools; coreutils = bootstrapTools;
-      libc = stdenvLinuxGlibc;};
-    extraAttrs = {glibc = stdenvLinuxGlibc;};
+    gcc = wrapGCC {
+      binutils = bootstrapTools;
+      coreutils = bootstrapTools;
+      libc = stdenvLinuxGlibc;
+    };
+    extraAttrs = {
+      glibc = stdenvLinuxGlibc;
+      inherit (stdenvLinuxBoot1Pkgs) perl;
+    };
     inherit fetchurl;
   }) ["gcc" "binutils"];
 
@@ -186,6 +195,9 @@ rec {
       gcc = stdenvLinuxBoot2Pkgs.gcc.gcc;
       name = "";
     };
+    extraAttrs = {
+      inherit (stdenvLinuxBoot1Pkgs) perl;
+    };
     inherit fetchurl;
   };
 
@@ -196,6 +208,7 @@ rec {
     bootStdenv = stdenvLinuxBoot3;
   };
 
+  
   # 8) Construct the final stdenv.  It uses the Glibc, GCC and
   #    Binutils built above, and adds in dynamically linked versions
   #    of all other tools.