summary refs log tree commit diff
path: root/pkgs/shells
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2009-03-20 16:49:02 +0000
committerEelco Dolstra <eelco.dolstra@logicblox.com>2009-03-20 16:49:02 +0000
commitd8e436c74211ca05cc0479edc89115acb408639d (patch)
tree797e5aba1d71d719c2364cf52e3522714f1246ac /pkgs/shells
parentf77e783622140c711d9bacc634e8cf99a964dd39 (diff)
parentbec9f4b0c37fa187d7e14723811a51e2c212b97a (diff)
downloadnixlib-d8e436c74211ca05cc0479edc89115acb408639d.tar
nixlib-d8e436c74211ca05cc0479edc89115acb408639d.tar.gz
nixlib-d8e436c74211ca05cc0479edc89115acb408639d.tar.bz2
nixlib-d8e436c74211ca05cc0479edc89115acb408639d.tar.lz
nixlib-d8e436c74211ca05cc0479edc89115acb408639d.tar.xz
nixlib-d8e436c74211ca05cc0479edc89115acb408639d.tar.zst
nixlib-d8e436c74211ca05cc0479edc89115acb408639d.zip
* Sync with the trunk.
svn path=/nixpkgs/branches/stdenv-updates/; revision=14634
Diffstat (limited to 'pkgs/shells')
-rw-r--r--pkgs/shells/bash/4.0.nix44
1 files changed, 44 insertions, 0 deletions
diff --git a/pkgs/shells/bash/4.0.nix b/pkgs/shells/bash/4.0.nix
new file mode 100644
index 000000000000..0554039f279c
--- /dev/null
+++ b/pkgs/shells/bash/4.0.nix
@@ -0,0 +1,44 @@
+{stdenv, fetchurl, bison, interactive ? false, ncurses ? null, texinfo ? null, readline ? null}:
+
+assert interactive -> ncurses != null;
+assert interactive -> readline != null;
+
+stdenv.mkDerivation {
+  name = "bash-4.0";
+
+  src = fetchurl {
+    url = mirror://gnu/bash/bash-4.0.tar.gz;
+    sha256 = "9793d394f640a95030c77d5ac989724afe196921956db741bcaf141801c50518";
+  };
+
+  NIX_CFLAGS_COMPILE = ''
+    -DSYS_BASHRC="/etc/bashrc"
+    -DSYS_BASH_LOGOUT="/etc/bash_logout"
+    -DDEFAULT_PATH_VALUE="/no-such-path"
+    -DSTANDARD_UTILS_PATH="/no-such-path"
+    -DNON_INTERACTIVE_LOGIN_SHELLS
+    -DSSH_SOURCE_BASHRC
+  '';
+
+  postInstall = "ln -s bash $out/bin/sh";
+
+  patches = [
+    # For dietlibc builds.
+    ./winsize.patch
+  ];
+
+  configureFlags = if interactive then "--enable-readline --with-installed-readline" else "";
+
+  # !!! Bison is only needed for bash-3.2 (because of bash32-001.patch)
+  buildInputs = [bison]
+    ++ stdenv.lib.optional (texinfo != null) texinfo
+    ++ stdenv.lib.optional interactive readline
+    ++ stdenv.lib.optional interactive ncurses;
+
+  meta = {
+    homepage = http://www.gnu.org/software/bash/;
+    description =
+      "GNU Bourne-Again Shell, the de facto standard shell on Linux" +
+        (if interactive then " (for interactive use)" else "");
+  };
+}